Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tree: b2582e1a67
Fetching contributors…

Cannot retrieve contributors at this time

45 lines (40 sloc) 1.894 kb
{
"name": "perl",
"description": "Installs perl and provides a define for maintaining CPAN modules",
"long_description": "= DESCRIPTION:\n\nManages Perl installation and provides cpan_module, to install modules \nfrom... CPAN.\n\n= REQUIREMENTS:\n\nThis cookbook requires at least Ohai 0.3.0 to get the Perl language data:\n\n{\n \"perl\": {\n \"version\": \"5.10.0\",\n \"archname\": \"x86_64-linux-gnu-thread-multi\"\n }\n}\n\nTested with Perl 5.8.8 and 5.10.0.\n\n= USAGE:\n\nTo install a module from CPAN:\n\n cpan_module \"App::Munchies\"\n\nOptionally, installation can forced with the 'force' parameter.\n\n cpan_module \"App::Munchies\"\n force true\n end\n\n= LICENSE and AUTHOR:\n\nAuthor:: Joshua Timberman (<joshua@opscode.com>)\nCopyright:: 2009, Opscode, Inc.\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n\n",
"maintainer": "Opscode, Inc.",
"maintainer_email": "cookbooks@opscode.com",
"license": "Apache 2.0",
"platforms": {
"ubuntu": [
],
"debian": [
],
"centos": [
],
"redhat": [
],
"arch": [
]
},
"dependencies": {
},
"recommendations": {
},
"suggestions": {
},
"conflicting": {
},
"providing": {
},
"replacing": {
},
"attributes": {
},
"groupings": {
},
"recipes": {
"perl": "Installs perl and provides a script to install cpan modules"
},
"version": "0.10.0"
}
Jump to Line
Something went wrong with that request. Please try again.