Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[ISSUE] The Drawing tools left round marks on most strokes #1154

Closed
Kaikogf opened this Issue Jan 6, 2019 · 11 comments

Comments

Projects
None yet
6 participants
@Kaikogf
Copy link

Kaikogf commented Jan 6, 2019

Issue Summary

While laying strokes using different drawing tools, most of the strokes have a dot at the end of the stroke

  • Pencil2D Version:
    20/12/2018
  • Operating System:
    Win 8.1 x 64 bits
  • RAM Size:
    32GB
  • Graphics Tablet:
    HUION HD185

defeito pencil2d

@Kaikogf

This comment has been minimized.

Copy link
Author

Kaikogf commented Jan 6, 2019

Just open Pencil2D and select a drawing tool and make a stroke to check this issue

@CandyFace

This comment has been minimized.

Copy link
Member

CandyFace commented Jan 6, 2019

Related to #677

It's not a consistent bug though, I have tried to replicate it using 3 different tablet (Huion, Artisul and wacom) brands without success.

@scribblemaniac

This comment has been minimized.

Copy link
Member

scribblemaniac commented Jan 6, 2019

@Kaikogf What is your operating system?

@davidlamhauge

This comment has been minimized.

Copy link
Contributor

davidlamhauge commented Jan 6, 2019

XP-PEN 22E pro on MacBook and HUION 580 on Ubuntu 18.04 tested: No problems... Can't replicate the error.

@chchwy

This comment has been minimized.

Copy link
Member

chchwy commented Jan 6, 2019

I can replicate this issue. Win 10 + Wacom Bamboo CTH670

@Jose-Moreno

This comment has been minimized.

Copy link
Member

Jose-Moreno commented Jan 6, 2019

@davidlamhauge @chchwy @Kaikogf We were on discord with Candyface and Scribblemaniac a few hours ago testing 667 which is related to this one. Scribblemaniac managed to implement a few fixes while I kept testing compiled versions with 5.12. It seems 5.12 didn't fix out issue, but the changes made to scribblearea.cpp did you can read the history in the #general-development channel hopefully a PR will be made soon so KaikoGF can test as well with a nightly build to close both issues soon enough.

@Kaikogf

This comment has been minimized.

Copy link
Author

Kaikogf commented Jan 7, 2019

@scribblemaniac > @Kaikogf What is your operating system?

Win 8.1 x 64 bits

@Kaikogf

This comment has been minimized.

Copy link
Author

Kaikogf commented Jan 7, 2019

I managed to build the last code [07/01/2019] in order to test this issue, and it is still present.

And it is related to #677, as @CandyFace mentioned

@Jose-Moreno

This comment has been minimized.

Copy link
Member

Jose-Moreno commented Jan 7, 2019

@Kaikogf The fix we were testing before is still not merged, so wait a bit until it is reviewed 🙂

@Jose-Moreno

This comment has been minimized.

Copy link
Member

Jose-Moreno commented Feb 1, 2019

@Kaikogf Can you please test nightly build for JAN 30th 2019 and confirm if this has been fixed for you? Here's a direct link to the build.
Win 64: https://drive.google.com/open?id=12ekVl_44GTCGJLh_3zcyjLhlwa6jAoXV

@Kaikogf

This comment has been minimized.

Copy link
Author

Kaikogf commented Feb 9, 2019

@Jose-Moreno
Tested here with the build you provided and the round dots are no longer present. So I am going to close this issue

Thank you!

@Kaikogf Kaikogf closed this Feb 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.