Permalink
Browse files

Remove Jeweler because it creates messy gemspecs and is redundant

  • Loading branch information...
sferik committed Oct 8, 2010
1 parent 9c0e62b commit 09692fc5f1d5f6f00fc8100f1487273e54da47cb
Showing with 26 additions and 142 deletions.
  1. +0 −10 Gemfile.lock
  2. +4 −27 Rakefile
  3. +0 −1 VERSION
  4. +19 −104 faraday.gemspec
  5. +3 −0 lib/faraday/version.rb
View
@@ -11,13 +11,6 @@ GEM
specs:
addressable (2.1.2)
columnize (0.3.1)
- gemcutter (0.6.1)
- git (1.2.5)
- jeweler (1.4.0)
- gemcutter (>= 0.1.0)
- git (>= 1.2.5)
- rubyforge (>= 2.0.0)
- json_pure (1.4.6)
linecache (0.43)
multipart-post (1.0.1)
rack (1.0.1)
@@ -27,8 +20,6 @@ GEM
ruby-debug-base (~> 0.10.3.0)
ruby-debug-base (0.10.3)
linecache (>= 0.3)
- rubyforge (2.0.4)
- json_pure (>= 1.1.7)
test-unit (2.1.1)
PLATFORMS
@@ -37,7 +28,6 @@ PLATFORMS
DEPENDENCIES
addressable (~> 2.1.1)
faraday!
- jeweler (~> 1.4.0)
multipart-post (~> 1.0.1)
rack (~> 1.0.1)
rake (~> 0.8.7)
View
@@ -1,29 +1,7 @@
-require 'rubygems'
require 'rake'
+require 'bundler'
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "faraday"
- gem.summary = "HTTP/REST API client library"
- gem.description = "HTTP/REST API client library with pluggable components"
- gem.email = "technoweenie@gmail.com"
- gem.homepage = "http://github.com/technoweenie/faraday"
- gem.authors = ["rick"]
- gem.add_development_dependency "jeweler", "~> 1.4.0"
- gem.add_development_dependency "rake", "~> 0.8.7"
- gem.add_development_dependency "ruby-debug", "~> 0.10.3"
- gem.add_development_dependency "test-unit", "~> 2.1.1"
- gem.add_dependency "rack", "~> 1.0.1"
- gem.add_dependency "multipart-post", "~> 1.0.1"
- gem.add_dependency "addressable", "~> 2.1.1"
- end
- Jeweler::GemcutterTasks.new
-
- task :test => :check_dependencies
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
+Bundler::GemHelper.install_tasks
require 'rake/testtask'
Rake::TestTask.new(:test) do |test|
@@ -48,11 +26,10 @@ end
task :default => :test
require 'rake/rdoctask'
+require File.expand_path("../lib/faraday/version", __FILE__)
Rake::RDocTask.new do |rdoc|
- version = File.exist?('VERSION') ? File.read('VERSION') : ""
-
rdoc.rdoc_dir = 'rdoc'
- rdoc.title = "faraday #{version}"
+ rdoc.title = "faraday #{Faraday::VERSION}"
rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/**/*.rb')
end
View
@@ -1 +0,0 @@
-0.4.6
View
@@ -1,110 +1,25 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+require File.expand_path("../lib/faraday/version", __FILE__)
Gem::Specification.new do |s|
- s.name = %q{faraday}
- s.version = "0.4.6"
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.add_development_dependency('rake', ["~> 0.8.7"])
+ s.add_development_dependency('ruby-debug', ["~> 0.10.3"])
+ s.add_development_dependency('test-unit', ["~> 2.1.1"])
+ s.add_runtime_dependency('rack', ["~> 1.0.1"])
+ s.add_runtime_dependency('multipart-post', ["~> 1.0.1"])
+ s.add_runtime_dependency('addressable', ["~> 2.1.1"])
+ s.name = 'faraday'
+ s.version = Faraday::VERSION
+ s.required_rubygems_version = Gem::Requirement.new(">= 1.3.6") if s.respond_to? :required_rubygems_version=
s.authors = ["rick"]
- s.date = %q{2010-10-08}
- s.description = %q{HTTP/REST API client library with pluggable components}
- s.email = %q{technoweenie@gmail.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".document",
- ".gitignore",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "faraday.gemspec",
- "lib/faraday.rb",
- "lib/faraday/adapter.rb",
- "lib/faraday/adapter/action_dispatch.rb",
- "lib/faraday/adapter/net_http.rb",
- "lib/faraday/adapter/patron.rb",
- "lib/faraday/adapter/test.rb",
- "lib/faraday/adapter/typhoeus.rb",
- "lib/faraday/builder.rb",
- "lib/faraday/connection.rb",
- "lib/faraday/error.rb",
- "lib/faraday/middleware.rb",
- "lib/faraday/request.rb",
- "lib/faraday/request/active_support_json.rb",
- "lib/faraday/request/yajl.rb",
- "lib/faraday/response.rb",
- "lib/faraday/response/active_support_json.rb",
- "lib/faraday/response/yajl.rb",
- "lib/faraday/upload_io.rb",
- "lib/faraday/utils.rb",
- "test/adapters/live_test.rb",
- "test/adapters/test_middleware_test.rb",
- "test/adapters/typhoeus_test.rb",
- "test/connection_app_test.rb",
- "test/connection_test.rb",
- "test/env_test.rb",
- "test/form_post_test.rb",
- "test/helper.rb",
- "test/live_server.rb",
- "test/multipart_test.rb",
- "test/request_middleware_test.rb",
- "test/response_middleware_test.rb"
- ]
- s.homepage = %q{http://github.com/technoweenie/faraday}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
s.summary = %q{HTTP/REST API client library}
- s.test_files = [
- "test/adapters/live_test.rb",
- "test/adapters/test_middleware_test.rb",
- "test/adapters/typhoeus_test.rb",
- "test/connection_app_test.rb",
- "test/connection_test.rb",
- "test/env_test.rb",
- "test/form_post_test.rb",
- "test/helper.rb",
- "test/live_server.rb",
- "test/multipart_test.rb",
- "test/request_middleware_test.rb",
- "test/response_middleware_test.rb"
- ]
-
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<jeweler>, ["~> 1.4.0"])
- s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
- s.add_development_dependency(%q<ruby-debug>, ["~> 0.10.3"])
- s.add_development_dependency(%q<test-unit>, ["~> 2.1.1"])
- s.add_runtime_dependency(%q<rack>, ["~> 1.0.1"])
- s.add_runtime_dependency(%q<multipart-post>, ["~> 1.0.1"])
- s.add_runtime_dependency(%q<addressable>, ["~> 2.1.1"])
- else
- s.add_dependency(%q<jeweler>, ["~> 1.4.0"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
- s.add_dependency(%q<ruby-debug>, ["~> 0.10.3"])
- s.add_dependency(%q<test-unit>, ["~> 2.1.1"])
- s.add_dependency(%q<rack>, ["~> 1.0.1"])
- s.add_dependency(%q<multipart-post>, ["~> 1.0.1"])
- s.add_dependency(%q<addressable>, ["~> 2.1.1"])
- end
- else
- s.add_dependency(%q<jeweler>, ["~> 1.4.0"])
- s.add_dependency(%q<rake>, ["~> 0.8.7"])
- s.add_dependency(%q<ruby-debug>, ["~> 0.10.3"])
- s.add_dependency(%q<test-unit>, ["~> 2.1.1"])
- s.add_dependency(%q<rack>, ["~> 1.0.1"])
- s.add_dependency(%q<multipart-post>, ["~> 1.0.1"])
- s.add_dependency(%q<addressable>, ["~> 2.1.1"])
- end
+ s.description = %q{HTTP/REST API client library with pluggable components}
+ s.email = ['technoweenie@gmail.com']
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.homepage = "http://github.com/technoweenie/faraday"
+ s.extra_rdoc_files = ['LICENSE', 'README.rdoc']
+ s.rdoc_options = ['--charset=UTF-8']
+ s.require_paths = ['lib']
end
-
View
@@ -0,0 +1,3 @@
+module Faraday
+ VERSION = "0.4.6"
+end

0 comments on commit 09692fc

Please sign in to comment.