Skip to content
Browse files

updated for sass gem, no more haml

  • Loading branch information...
1 parent aef8858 commit 6bcf5f4de45d1b994468ad51cec68298ed3d9c5e @pengwynn committed Apr 26, 2011
Showing with 11 additions and 22 deletions.
  1. +5 −15 Gemfile.lock
  2. +6 −6 guard-sass.gemspec
  3. +0 −1 lib/guard/sass.rb
View
20 Gemfile.lock
@@ -3,23 +3,14 @@ PATH
specs:
guard-sass (0.0.5)
guard (>= 0.2.1)
- haml (~> 3.0.0)
+ sass (~> 3.1.0)
GEM
remote: http://rubygems.org/
specs:
- configuration (1.1.0)
diff-lcs (1.1.2)
- guard (0.2.1)
- open_gem (~> 1.4.2)
- thor (~> 0.14.3)
- haml (3.0.22)
- launchy (0.3.7)
- configuration (>= 0.0.5)
- rake (>= 0.8.1)
- open_gem (1.4.2)
- launchy (~> 0.3.5)
- rake (0.8.7)
+ guard (0.3.4)
+ thor (~> 0.14.6)
rspec (2.0.1)
rspec-core (~> 2.0.1)
rspec-expectations (~> 2.0.1)
@@ -30,14 +21,13 @@ GEM
rspec-mocks (2.0.1)
rspec-core (~> 2.0.1)
rspec-expectations (~> 2.0.1)
- thor (0.14.3)
+ sass (3.1.0)
+ thor (0.14.6)
PLATFORMS
ruby
DEPENDENCIES
bundler (~> 1.0.2)
- guard (>= 0.2.1)
guard-sass!
- haml (~> 3.0.0)
rspec (~> 2.0.0.rc)
View
12 guard-sass.gemspec
@@ -11,16 +11,16 @@ Gem::Specification.new do |s|
s.homepage = 'http://rubygems.org/gems/guard-sass'
s.summary = 'Guard gem for Sass'
s.description = 'Guard::Sass automatically rebuilds sass (like sass --watch)'
-
+
s.required_rubygems_version = '>= 1.3.6'
s.rubyforge_project = 'guard-sass'
-
+
s.add_dependency 'guard', '>= 0.2.1'
- s.add_dependency 'haml', '~> 3.0.0'
-
+ s.add_dependency 'sass', '~> 3.1.0'
+
s.add_development_dependency 'bundler', '~> 1.0.2'
s.add_development_dependency 'rspec', '~> 2.0.0.rc'
-
+
s.files = Dir.glob('{lib}/**/*') + %w[LICENSE README.md]
s.require_path = 'lib'
-end
+end
View
1 lib/guard/sass.rb
@@ -1,6 +1,5 @@
require 'guard'
require 'guard/guard'
-
require 'sass'
module Guard

0 comments on commit 6bcf5f4

Please sign in to comment.
Something went wrong with that request. Please try again.