spring-core.jar is version 2.0.x, not 2.5.x #6

Closed
bjoerge opened this Issue Sep 26, 2011 · 3 comments

Comments

Projects
None yet
3 participants

bjoerge commented Sep 26, 2011

Seems like the version of the spring-core.jar shipped with is of version 2.0.x, and not 2.5.x as expected (all the manifest files in the spring-*.jar files seems to indicate that it should be version 2.5.5).

If you compare the list of methods here: http://static.springsource.org/spring/docs/2.5.x/api/org/springframework/util/ReflectionUtils.html with the list of methods in the ReflectionUtils.class of spring-core.jar in the source of this project, theres a lot of methods that are missing in this projects version.

Looks like this projects version has a better match with the api of the spring 2.0.x version: http://static.springsource.org/spring/docs/2.0.x/api/index.html

Cheers,
Bjørge

Owner

pepite commented Sep 26, 2011

That's weird. Which version of the spring module are you referring to?
I was under the impression we already moved to the 3.x spring
version...

2011/9/26 Bjørge Næss
reply@reply.github.com:

Seems like the version of the spring-core.jar shipped with  is of version 2.0.x, and not 2.5.x as expected (all the manifest files in the spring-*.jar files seems to indicate that it should be version 2.5.5).

If you compare the list of methods here: http://static.springsource.org/spring/docs/2.5.x/api/org/springframework/util/ReflectionUtils.html with the list of methods in the ReflectionUtils.class of spring-core.jar in the source of this project, theres a lot of methods that are missing in this projects version.

Looks like this projects version has a better match with the api of the spring 2.0.x version: http://static.springsource.org/spring/docs/2.0.x/api/index.html

Cheers,
Bjørge

Reply to this email directly or view it on GitHub:
#6

Nicolas Leroux

bjoerge commented Sep 26, 2011

If you look at the ReflectionUtils class in this jar: https://github.com/pepite/Play--framework-Spring-module/blob/master/lib/spring-core.jar it is missing the isEqualsMethod (and several others) that is present in Spring 2.5.x (and also in 3.x)...

Also, all the manifest files seems to refer to Spring 2.5.5, i.e. the manifest file in the above mentioned jar-file:

(...)
Export-Package: org.springframework.asm;version=2.5.5,org.springframew
ork.util.comparator;uses:=org.springframework.util;version=2.5.5,org.
springframework.metadata.commons;uses:="org.springframework.metadata, (...)

bjoerge closed this Sep 26, 2011

bjoerge reopened this Sep 26, 2011

Contributor

sliverc commented Sep 26, 2011

It would be great when the spring module would use dependency.yml. This way it would always be clear what version the spring module is using. Furthermore, a user of the spring module is able to change the version of spring as desired in its own application dependency.yml.

I've created a pull request to do so #7

pepite closed this Apr 25, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment