SystemRequirementsSupportedPlatforms

stockiNail edited this page Oct 12, 2015 · 3 revisions

System requirements

JEM is a Java application: it runs on Java Runtime Environment (JRE) version 6 or 7. It has been tested on Oracle Java SE 6 and 7 and on OpenJDK 6.

It's not a pure Java application because it's using Hyperic SIGAR framework to gather CPU/Memory consumptions (for both jobs and node). Furthermore, JEM creates always new process to execute jobs and for this reason it's current complaint with all UNIX systems (BASH shell is needed) and Windows.

To persist JEM information, a MySql instance is necessary. IBM DB2 and ORACLE are also supported (see persistence configuration).

Supported server platforms

The platform compatibility is the following:

Operating system Architecture Versions
Linux x86 2.2, 2.4, 2.6 kernels
Linux amd64 2.6 kernel
Linux ppc 2.6 kernel
Linux ppc64 2.6 kernel
Linux ia64 2.6 kernel
Windows x86 NT 4.0, 2000 Pro/Server, 2003 Server, XP, Vista, 2008 Server, 7
Windows x64 2003 Server, Vista, 2008 Server, 7
Solaris sparc-32 2.6, 7, 8, 9, 10
Solaris sparc-64
Solaris x86 8, 9, 10
Solaris x64
AIX ppc 4.3, 5.1, 5.2, 5.3, 6.1
AIX ppc64 5.2,5.3,6.1
HP-UX PA-RISC 11
HP-UX ia64 11

While Hyperic SIGAR only depends on the Linux kernel version, the following distributions have been certified:

Distribution Versions
Red Hat 6.2, 7.3, 8.0, 9.0
RHEL 3, 4, 5, 6
CentOS 3, 4, 5
Fedora 2, 3, 4, 5, 6, 7, 8, 9, 10
SuSE 8, 9, 10, 11
Ubuntu 6.06, 8.04, 8.10, 9.04
Debian 2.6, 3.0, 3.1, 3.2, 4.0, 5.0
VMware ESX 2.x, 3.0
Xen Server 3.1, 3.2, 4.0, 4.1, 5.0
Slackware 10, 11
Mandrake 10
Scientific Linux 5
Gentoo

Supported servlet container

JEM, on web site, is a pure Java application: it runs on Java Runtime Environment (JRE) version 6 or higher. It has been tested Oracle Java SE 6 and 7 and on OpenJDK 6.

It has been tested on Apache Tomcat version 6 and 7 and on Jetty.

No restrictions to use in another servlet container or application server.

Supported client browser

JEM user interface is developed on GWT framework and it's using CSS3.

Here the list of tested browser:

Browser
IE 8 (with some restrictions)
IE 9, IE 10, IE 11
Firefox
Chrome
Safari
Clone this wiki locally
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.