Skip to content
Permalink
Browse files

Disable the Cloud Launcher. Too expensive for how underused (3 people…

…?) it is.
  • Loading branch information
bradfitz committed Jul 29, 2019
1 parent 6db9cb8 commit c9f78d02adf9740f3b8d403a1418554293cc9f41
Showing with 4 additions and 0 deletions.
  1. +2 −0 go.mod
  2. +2 −0 website/pk-web/pkweb.go
2 go.mod
@@ -1,5 +1,7 @@
module perkeep.org

go 1.12

require (
bazil.org/fuse v0.0.0-20160811212531-371fbbdaa898
cloud.google.com/go v0.39.0
@@ -546,6 +546,7 @@ func gceDeployHandlerConfig() (*gce.Config, error) {
// - neither CAMLI_GCE_CLIENTID is set, nor launcher-config.json is found in the
// camlistore server config dir.
func gceDeployHandler(prefix string) (*gce.DeployHandler, error) {
return nil, errors.New("The Perkeep Cloud Launcher is no longer available.")
var hostPort string
var err error
scheme := "https"
@@ -909,6 +910,7 @@ func main() {
gceLauncher, err := gceDeployHandler("/launch/")
if err != nil {
log.Printf("Not installing GCE /launch/ handler: %v", err)
err := err
mux.HandleFunc("/launch/", func(w http.ResponseWriter, r *http.Request) {
http.Error(w, fmt.Sprintf("GCE launcher disabled: %v", err), 500)
})

0 comments on commit c9f78d0

Please sign in to comment.
You can’t perform that action at this time.