Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

carton.snapshot can't handle version requirement such as Net::HTTP >= 0, != 6.04, != 6.05 #117

Closed
lestrrat opened this Issue Aug 4, 2013 · 4 comments

Comments

Projects
None yet
2 participants

lestrrat commented Aug 4, 2013

Carton::Snapshot::Parser barfs on " Net::HTTP >= 0, != 6.04, != 6.05", which I got from including Net-Twitter-Lite-0.12002

Contributor

miyagawa commented Aug 4, 2013

can you describe a step to reproduce?

lestrrat added a commit to lestrrat/carton that referenced this issue Aug 4, 2013

lestrrat commented Aug 4, 2013

I added a test case... or did you want the actual "steps to reproduce the cpanfile.snapshot file"?

Contributor

miyagawa commented Aug 4, 2013

Yeah i wanted the (user) step to reproduce the file.

Contributor

miyagawa commented Aug 4, 2013

sorry, "Can't handle" is a very vague bug report. I wanted what you had in your cpanfile and what error as you saw.

@miyagawa miyagawa closed this in 4a2a4e1 Aug 5, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment