Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 44 lines (34 sloc) 1.36 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
If you are on a system where you can run the Makefile.PL and use make,
then the package can be installed using the normal MakeMaker process,
that is

  gunzip perl-ldap-*.**.tar.gz
  tar xvf perl-ldap-*.**
  cd perl-ldap-*.**
  perl Makefile.PL
  make
  make test
  make install

If you are on a system where this is not possible you will need to perform
the following, after ensuring that any dependant libraries are installed
(see README)

  perl -V

This will output information about your perl installation. Near the end
of this you will see something like

  @INC:
    /usr/local/lib/perl5/5.6.0/i686-linux
    /usr/local/lib/perl5/5.6.0
    /usr/local/lib/perl5/site_perl/5.6.0/i686-linux
    /usr/local/lib/perl5/site_perl/5.6.0
    /usr/local/lib/perl5/site_perl
    .

You need to find the site_perl directory with the perl version specified,
in this case it is /usr/local/lib/perl5/site_perl/5.6.0

You then need to copy the contents of the lib/ directory from the
distribution with the equivalent of the following for your platform.

  gunzip perl-ldap-*.**.tar.gz
  tar xvf perl-ldap-*.**
  cd perl-ldap-*.**/lib
  cp -r * /usr/local/lib/perl5/site_perl/5.6.0

To use the basics of perl-ldap there is only one dependancy,
Convert::ASN1, all others are optional depending on if you want to use
a given functionality. See the README file for a list.
Something went wrong with that request. Please try again.