Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bleadperl v5.21.8-322-gd27f4b9 breaks ETHER/Devel-Declare-0.006017.tar.gz #14521

Closed
p5pRT opened this issue Feb 18, 2015 · 8 comments
Labels

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented Feb 18, 2015

Migrated from rt.perl.org#123865 (status was 'resolved')

Searchable as RT123865$

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Feb 18, 2015

From @andk

bisect


commit d27f4b9
Author​: Father Chrysostomos <sprout@​cpan.org>
Date​: Sun Feb 15 21​:22​:00 2015 -0800

  [perl #123712] Don’t check sub_inwhat

sample report


http​://www.cpantesters.org/cpan/report/cd9dfae6-b5e4-11e4-8cc6-8f928971dd2f

perl -V


Summary of my perl5 (revision 5 version 21 subversion 9) configuration​:
  Commit id​: d27f4b9
  Platform​:
  osname=linux, osvers=3.16.0-4-amd64, archname=x86_64-linux-ld
  uname='linux k83 3.16.0-4-amd64 #1 smp debian 3.16.7-ckt2-1 (2014-12-08) x86_64 gnulinux '
  config_args='-Dprefix=/home/sand/src/perl/repoperls/installed-perls/perl/v5.21.8-322-gd27f4b9/127e -Dmyhostname=k83 -Dinstallusrbinperl=n -Uversiononly -Dusedevel -des -Ui_db -Uuseithreads -Duselongdouble -DDEBUGGING=-g'
  hint=recommended, useposix=true, d_sigaction=define
  useithreads=undef, usemultiplicity=undef
  use64bitint=define, use64bitall=define, uselongdouble=define
  usemymalloc=n, bincompat5005=undef
  Compiler​:
  cc='cc', ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2',
  optimize='-O2 -g',
  cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
  ccversion='', gccversion='4.9.2', gccosandvers=''
  intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678, doublekind=3
  d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16, longdblkind=3
  ivtype='long', ivsize=8, nvtype='long double', nvsize=16, Off_t='off_t', lseeksize=8
  alignbytes=16, prototype=define
  Linker and Libraries​:
  ld='cc', ldflags =' -fstack-protector-strong -L/usr/local/lib'
  libpth=/usr/local/lib /usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
  libs=-lpthread -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
  perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
  libc=libc-2.19.so, so=so, useshrplib=false, libperl=libperl.a
  gnulibc_version='2.19'
  Dynamic Linking​:
  dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
  cccdlflags='-fPIC', lddlflags='-shared -O2 -g -L/usr/local/lib -fstack-protector-strong'

Characteristics of this binary (from libperl)​:
  Compile-time options​: HAS_TIMES PERLIO_LAYERS PERL_DONT_CREATE_GVSV
  PERL_HASH_FUNC_ONE_AT_A_TIME_HARD PERL_MALLOC_WRAP
  PERL_NEW_COPY_ON_WRITE PERL_PRESERVE_IVUV
  PERL_USE_DEVEL USE_64_BIT_ALL USE_64_BIT_INT
  USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE
  USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_LOCALE_TIME
  USE_LONG_DOUBLE USE_PERLIO USE_PERL_ATOF
  Built under linux
  Compiled at Feb 18 2015 04​:32​:44
  @​INC​:
  /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.8-322-gd27f4b9/127e/lib/site_perl/5.21.9/x86_64-linux-ld
  /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.8-322-gd27f4b9/127e/lib/site_perl/5.21.9
  /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.8-322-gd27f4b9/127e/lib/5.21.9/x86_64-linux-ld
  /home/sand/src/perl/repoperls/installed-perls/perl/v5.21.8-322-gd27f4b9/127e/lib/5.21.9
  .

--
andreas

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 23, 2015

From @wolfsage

On Tue Feb 17 19​:47​:06 2015, andreas.koenig.7os6VVqR@​franz.ak.mind.de wrote​:

bisect
------
commit d27f4b9
Author​: Father Chrysostomos <sprout@​cpan.org>
Date​: Sun Feb 15 21​:22​:00 2015 -0800

[perl #123712] Don’t check sub_inwhat

Possible patch attached. Review would be good.

Makes the dist pass tests on 5.21.9 (where it was broken), also tested on 5.21.4, 5.14.4, 5.8.8.

-- Matthew Horsfall (alh)

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 23, 2015

From @wolfsage

dont_use_sub_inwhat.patch
--- Devel-Declare-0.006017/stolen_chunk_of_toke.c	2015-03-23 15:28:33.230055110 -0400
+++ Devel-Declare-0.006017-patched/stolen_chunk_of_toke.c	2015-03-23 15:27:48.402102674 -0400
@@ -342,7 +342,7 @@
 	 * of the buffer, we're not reading from a source filter, and
 	 * we're in normal lexing mode
 	 */
-	if (s < PL_bufend || !PL_rsfp || PL_sublex_info.sub_inwhat ||
+	if (s < PL_bufend || !PL_rsfp || PL_lex_inwhat ||
 		PL_lex_state == LEX_FORMLINE)
 	    return s;
 
@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 23, 2015

The RT System itself - Status changed from 'new' to 'open'

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 23, 2015

From perl5-porters@perl.org

Matthew Horsfall wrote​:

Possible patch attached. Review would be good.

Thank you for beating me to it.

I think your patch is exactly what is needed.

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 24, 2015

From @wolfsage

On Mon, Mar 23, 2015 at 5​:55 PM, <Father@​lists-nntp.develooper.com> wrote​:

Matthew Horsfall wrote​:

Possible patch attached. Review would be good.

Thank you for beating me to it.

I think your patch is exactly what is needed.

No prob, thanks for the review.

I've put the patch in Devel​::Declare's RT queue.

-- Matthew Horsfall (alh)

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 24, 2015

From @karenetheridge

Devel-Declare-0.006018 has been uploaded. many thanks!

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Mar 24, 2015

@karenetheridge - Status changed from 'open' to 'resolved'

@p5pRT p5pRT closed this Mar 24, 2015
@p5pRT p5pRT added the Severity Low label Oct 19, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.