Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

CPAN.pm still buggy in RC1 #15978

Closed
p5pRT opened this issue May 14, 2017 · 9 comments
Labels

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented May 14, 2017

Migrated from rt.perl.org#131312 (status was 'resolved')

Searchable as RT131312$

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented May 14, 2017

From @andk

https://rt.cpan.org/Ticket/Display.html?id=121665

As far as I can see the real fix for this would be in Module​::Build but
the amount of work required to fix it there is unknown at the moment.
Leon explained it in toddr/perl#14

The workarounds known so far would require the end user to change
their configuration, something like

  o conf mbuild_install_build_command "sudo -E ./Build"

or

  o conf mbuild_install_build_command "sudo env PERL_USE_UNSAFE_INC=1 ./Build"

Which is not looking very attractive to me.

Please make this ticket a showstopper for 5.26

--
andreas

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented May 14, 2017

From @Leont

On Sun, May 14, 2017 at 8​:56 AM, Andreas J. Koenig via RT <
perlbug-followup@​perl.org> wrote​:

# New Ticket Created by (Andreas J. Koenig)
# Please include the string​: [perl #131312]
# in the subject line of all future correspondence about this issue.
# <URL​: https://rt-archive.perl.org/perl5/Ticket/Display.html?id=131312 >

https://rt.cpan.org/Ticket/Display.html?id=121665

As far as I can see the real fix for this would be in Module​::Build but
the amount of work required to fix it there is unknown at the moment.
Leon explained it in toddr/perl#14

The workarounds known so far would require the end user to change
their configuration, something like

o conf mbuild_install_build_command "sudo -E ./Build"

or

o conf mbuild_install_build_command "sudo env PERL_USE_UNSAFE_INC=1
./Build"

Which is not looking very attractive to me.

Please make this ticket a showstopper for 5.26

I've just released Module​::Build 0.42_23, which should solve this issue.

Leon

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented May 14, 2017

The RT System itself - Status changed from 'new' to 'open'

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented May 15, 2017

From @iabyn

On Sun, May 14, 2017 at 01​:30​:12PM +0200, Leon Timmermans wrote​:

On Sun, May 14, 2017 at 8​:56 AM, Andreas J. Koenig via RT <

https://rt.cpan.org/Ticket/Display.html?id=121665

As far as I can see the real fix for this would be in Module​::Build but
the amount of work required to fix it there is unknown at the moment.
Leon explained it in toddr/perl#14

The workarounds known so far would require the end user to change
their configuration, something like

o conf mbuild_install_build_command "sudo -E ./Build"

or

o conf mbuild_install_build_command "sudo env PERL_USE_UNSAFE_INC=1
./Build"

Which is not looking very attractive to me.

Please make this ticket a showstopper for 5.26

I've just released Module​::Build 0.42_23, which should solve this issue.

Does this mean nothing now needs fixing in blead for RC2?

--
No matter how many dust sheets you use, you will get paint on the carpet.

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented May 15, 2017

From @Leont

On Mon, May 15, 2017 at 10​:07 AM, Dave Mitchell <davem@​iabyn.com> wrote​:

Does this mean nothing now needs fixing in blead for RC2?

Correct. I do need to make a non-devrelease of Module​::Build before 5,26 is
out though.

Leon

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented May 16, 2017

From @andk

On Mon, 15 May 2017 14​:22​:41 -0700, "Leon Timmermans via RT" <perlbug-followup@​perl.org> said​:

  > On Mon, May 15, 2017 at 10​:07 AM, Dave Mitchell <davem@​iabyn.com> wrote​:

Does this mean nothing now needs fixing in blead for RC2?

  > Correct. I do need to make a non-devrelease of Module​::Build before 5,26 is
  > out though.

Agreed.

--
andreas

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Dec 23, 2017

From @jkeenan

On Tue, 16 May 2017 02​:06​:18 GMT, andreas.koenig.7os6VVqR@​franz.ak.mind.de wrote​:

On Mon, 15 May 2017 14​:22​:41 -0700, "Leon Timmermans via RT"
<perlbug-followup@​perl.org> said​:

On Mon, May 15, 2017 at 10​:07 AM, Dave Mitchell <davem@​iabyn.com>
wrote​:

Does this mean nothing now needs fixing in blead for RC2?

Correct. I do need to make a non-devrelease of Module​::Build before
5,26 is
out though.

Agreed.

Is there anything more that needs to be done for this ticket?

Thank you very much.
--
James E Keenan (jkeenan@​cpan.org)

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Dec 28, 2017

From @jkeenan

On Sat, 23 Dec 2017 14​:17​:34 GMT, jkeenan wrote​:

On Tue, 16 May 2017 02​:06​:18 GMT,
andreas.koenig.7os6VVqR@​franz.ak.mind.de wrote​:

On Mon, 15 May 2017 14​:22​:41 -0700, "Leon Timmermans via RT"
<perlbug-followup@​perl.org> said​:

On Mon, May 15, 2017 at 10​:07 AM, Dave Mitchell <davem@​iabyn.com>
wrote​:

Does this mean nothing now needs fixing in blead for RC2?

Correct. I do need to make a non-devrelease of Module​::Build before
5,26 is
out though.

Agreed.

Is there anything more that needs to be done for this ticket?

Thank you very much.

No one cited anything more that needs to be done in this ticket, so I'm closing it (as Resolved, since it was left over from the previous development cycle).

Thank you very much.

--
James E Keenan (jkeenan@​cpan.org)

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Dec 28, 2017

@jkeenan - Status changed from 'open' to 'resolved'

@p5pRT p5pRT closed this Dec 28, 2017
@p5pRT p5pRT added the Severity Low label Oct 19, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.