Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No subject provided #902

Closed
p5pRT opened this issue Nov 30, 1999 · 5 comments

Comments

@p5pRT
Copy link
Collaborator

@p5pRT p5pRT commented Nov 30, 1999

Migrated from rt.perl.org#1836 (status was 'resolved')

Searchable as RT1836$

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Nov 30, 1999

From Bridget.Neequaye@compaq.com

I download a complied version of perl 5,00404 for alpha-dec-osf (OSF1 ,
V4.0) , The aim was to get sybperl working. Sybperl had a couple of
warning messages (i.e make) but failed at the test stage (i.e make test)
with main error messages

============================================================================
"unresolved symbol in /usr/people.....libsybdb.so​: getnodebynanme at
/usr/opt..../DynaLoader.pm line 166 "
at .././blib/lib/Sybase/BCP.pm line 278
BEGIN failed...compilation aborted at t/bcp.t line 14

Perl -V​:LIBS gives -lgdbm -ldbm -ldb -lm

Is the problem due to the db library ? how do I remove this from the
version of perl I have without having to compile and possibly not get even
perl running.

HELP

Thanks

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Nov 30, 1999

From [Unknown Contact. See original ticket]

I download a complied version of perl 5,00404 for alpha-dec-osf (OSF1 ,
V4.0) , The aim was to get sybperl working. Sybperl had a couple of
warning messages (i.e make) but failed at the test stage (i.e make test)
with main error messages

This version of Perl is outdated. Current stable version is 5.005_03.
To communicate with databases, you should look at DBI module, and for
Sybase, DBD​::Sybase.

For further information on database acesss, you'd better post to the following
lists​:

<dbi-dev@​fugue.com> for compile/install/bug problems

and

<dbi-users@​fugue.com> for using DBI related issues.

Regards,

François

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Dec 1, 1999

From [Unknown Contact. See original ticket]

François Désarménien wrote​:

I download a complied version of perl 5,00404 for alpha-dec-osf (OSF1 ,
V4.0) , The aim was to get sybperl working. Sybperl had a couple of
warning messages (i.e make) but failed at the test stage (i.e make test)
with main error messages

Sybperl related errors should be directed to the sybperl mailing list,
at sybperl-l@​listproc.net. See my web page for subscription details.

This version of Perl is outdated. Current stable version is 5.005_03.
To communicate with databases, you should look at DBI module, and for
Sybase, DBD​::Sybase.

Note that sybperl is a perfectly valid solution for Sybase access, and is
actively supported.

Michael
--
Michael Peppler -||- Data Migrations Inc.
mpeppler@​peppler.org -||- http​://www.mbay.net/~mpeppler
Int. Sybase User Group -||- http​://www.isug.com
Sybase on Linux mailing list​: ase-linux-list@​isug.com

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Dec 2, 1999

From [Unknown Contact. See original ticket]

Hi

Thanks everyone for help found the problem.

I found the undefined symbol getnodebyname was located in the net_stub
library.

I modified the CONFIG file and had in the extra libs section :

EXTRA_LIBS=-linsck -ltli -ldnet_stub -lsydb -lsdna

When running :

perl Makefile.PL

for some obscure reason the two libraries -ltli -ldnet_stub were not
included in the EXTRALIBS and LDLOADDLIBS parameters of the Makefile in the
Dblib directory. I had to manually amend the Makefile and add to EXTRALIBS
& LDLOADDLIBS :

-ltli -ldnet_stub.

I was then able to do a make test which was successful and then make
install.

Bridget

  -----Original Message-----
  From​: Michael Peppler [mailto​:mpeppler@​peppler.org]
  Sent​: 01 December 1999 15​:15
  To​: François Désarménien
  Cc​: Neequaye, Bridget; perl5-porters@​perl.org
  Subject​: Re​: [ID 19991130.001]

  François Désarménien wrote​:
  >
  > > I download a complied version of perl 5,00404 for
alpha-dec-osf (OSF1 ,
  > > V4.0) , The aim was to get sybperl working. Sybperl
had a couple of
  > > warning messages (i.e make) but failed at the test
stage (i.e make test)
  > > with main error messages

  Sybperl related errors should be directed to the sybperl
mailing list,
  at sybperl-l@​listproc.net. See my web page for subscription
details.

  >
  > This version of Perl is outdated. Current stable version
is 5.005_03.
  > To communicate with databases, you should look at DBI
module, and for
  > Sybase, DBD​::Sybase.

  Note that sybperl is a perfectly valid solution for Sybase
access, and is
  actively supported.

  Michael
  --
  Michael Peppler -||- Data Migrations Inc.
  mpeppler@​peppler.org -||- http​://www.mbay.net/~mpeppler
  Int. Sybase User Group -||- http​://www.isug.com
  Sybase on Linux mailing list​: ase-linux-list@​isug.com

@p5pRT

This comment has been minimized.

Copy link
Collaborator Author

@p5pRT p5pRT commented Dec 2, 1999

From [Unknown Contact. See original ticket]

Neequaye, Bridget writes​:

I modified the CONFIG file and had in the extra libs section :

EXTRA_LIBS=3D-linsck -ltli -ldnet_stub -lsydb -lsdna

When running :

perl Makefile.PL =20

for some obscure reason the two libraries -ltli -ldnet_stub were not
included in the EXTRALIBS and LDLOADDLIBS parameters of the Makefile in =
the
Dblib directory.

Did you get

  Warning (probably harmless)​: cannot find -ltli

? If yes, then you need to check the logic of library search. The
code which does it is in ExtUtils/Liblist.pm (sp?).

Ilya

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.