Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Compile to ES5 #34

Closed
jwworth opened this Issue Aug 30, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@jwworth
Copy link

jwworth commented Aug 30, 2018

Thanks for creating this; it's really cool!

We're trying to use this library with create-react-app, which requires that dependencies be compiled to ES5 as a build step:

https://github.com/facebook/create-react-app/blob/master/packages/react-scripts/template/README.md#npm-run-build-fails-to-minify

Would it be possible to publish the library pre-compiled to ES5? Thanks in advance if you have the time and interest in making this change.

@perogi perogi self-assigned this Oct 2, 2018

@perogi perogi added the question label Oct 2, 2018

@perogi

This comment has been minimized.

Copy link
Owner

perogi commented Oct 2, 2018

Hi @jwworth,

Thank you for your interest!

From your link it looks like upgrading to react-scripts@2.0.0 or above will fix this issue for your team. Funny that you post this, at my workplace we had exactly the same issue and upgraded to the latest react-scripts and everything worked fine. We eventually ejected react-scripts so we had more control over the project (I have to say ejecting was a bit of a pain but we got it working).

I'm not totally against precompiling it to ES5, I only want to try to keep the project as simplistic as possible on my end.

Thanks again and have a great day,
perogi.

@jwworth

This comment has been minimized.

Copy link
Author

jwworth commented Oct 2, 2018

Thanks for looking into this! I totally get it. Closing the issue.

@jwworth jwworth closed this Oct 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.