Skip to content

git installation instruction fa

AliReza AmirSamimi edited this page Apr 3, 2018 · 19 revisions

لینوکس

اگر از توزیع های معروفی مثل آرچ و فدورا و دبین و اوبونتو و اوپن سوزه استفاده میکنید ، توصیه میکنیم از شیوه های نصبی که در راهنما برای هر توزیع ذکر شده استفاده کنید. با نصب پرسپولیس از روی کد سورس شما آخرین تغییرات روی گیت هاب را نصب میکنید که ممکن است پایدار نباشد و برای آزمایش است.

قبل از هر چیز از نصب بودن این بسته های پیش نیاز روی سیستم عامل خود مطمئن شوید.

aria2 , libnotify-bin , python 3 , pyqt5 , qt5-svg , python3-requests , python3-setproctitle , python3-setuptools , sound-theme-freedesktop , python3-psutil , youtube-dl

در بعضی توزیع ها بسته python3-pyqt5.qtsvg هم باید نصب شود.

کد نصب پیش نیازها در آرچ لینوکس

    sudo pacman -S aria2 libnotify python-pyqt5 qt5-svg python-requests python-setproctitle python-setuptools sound-theme-freedesktop python-psutil youtube-dl

کد نصب پیش نیازها برای دبین و اوبونتو و ....

    sudo apt-get install aria2 sound-theme-freedesktop libnotify-bin python3-pyqt5 libqt5svg5 python3-requests python3-setproctitle python3-setuptools python3-psutil youtube-dl python3-pyqt5.qtsvg

کد نصب پیش نیازها در فدورا

    sudo dnf install aria2 sound-theme-freedesktop libnotify python3-qt5 qt5-qtsvg python3-requests python3-setproctitle python3-setuptools python3-psutil youtube-dl

پیش نیازهای اختیاری

اگر از میزکار هایی که با GTK+ نوشته شده اند(مثل گنوم ، سینامون، ایکس اف سی ای، ماتای، باجی و ...) استفاده میکنید، بهتر است این بسته را هم نصب کنید تا پرسپولیس ظاهر هماهنگ تری با میزکار شما داشته باشد:

Arch:

  yaourt -S adwaita-qt5

Debian,Ubuntu, Mint ,... :

  sudo apt-get install adwaita-qt

Fedora:

  sudo dnf install adwaita-qt
---------------------------------------------

بعد از نصب پیش نیازها این کدها را اجرا کنید

    git clone "https://github.com/persepolisdm/persepolis.git" 
    cd persepolis

برای نصب:

    sudo python3 setup.py install

برای خارج کردن از نصب

    sudo python3 uninstall.py

در بعضی توزیع های قدیمی تر مثل اوبونتو ۱۶.۰۴،نسخه پایتون ۲ نرم افزار youtube-dl نصب میشود. ولی پرسپولیس به نسخه پایتون ۳ این نرم افزار نیاز دارد. پس اگر توزیع شما اینطور هست و هنگام نصب خطا برای یوتیوب دی ال گرفتید، باید یوتیوب دی ال رو با pip3 نصب کنید.

   sudo apt install python3-pip 
   sudo pip3 install youtube-dl
You can’t perform that action at this time.