Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge pull request #20 from kriszyp/master

Updates for repl, version numbers
  • Loading branch information...
commit 0f13e7e533cbf19c7c5305f7c491972c13397115 2 parents 0f021f8 + 47153a5
@kriszyp kriszyp authored
Showing with 13 additions and 10 deletions.
  1. +4 −2 README.md
  2. +4 −3 index.js
  3. +5 −5 package.json
View
6 README.md
@@ -2,11 +2,13 @@ This is an example Wiki built with Persevere 2.0. It is recommended that you
install this package with NPM, so that
all dependencies will be automatically resolved:
+ mkdir node_modules
+ cd node_modules
npm install persevere-example-wiki
-And then go into the installed directory and run the index.js to start the wiki:
+And then go into the installed package directory and run the index.js to start the wiki:
- cd node_modules/persevere-example-wiki
+ cd persevere-example-wiki
node index.js
See [the Persevere installation instructions](http://persvr.org/Page/Installation) for
View
7 index.js
@@ -17,7 +17,8 @@ start(
// cascade from static to pintura REST handling
// the main place for static files accessible from the web
Static({urls:["/public"], root: "public", directoryListing: true}),
- Static({urls:["/packages"], root: require.resolve("pintura/pintura").replace(/pintura[\\\/]pintura.js$/,''), directoryListing: true}),
+ Static({urls:["/packages"], root: require('pintura/util/packages-dir'), directoryListing: true}),
+ // uncomment this for an optional explorer (needs the persvr package)
// Static({urls:["/explorer"], root: require.resolve("persevere/persvr").replace(/persvr.js$/,'') + "/explorer"}),
// this will provide access to the server side JS libraries from the client
pinturaApp
@@ -26,8 +27,8 @@ start(
//)
);
-if(require.main == module){
- require("repl").start();
+if(require.main == module && settings.repl){
+ require("repl").start('persevere>');
}
// this is just to ensure the static analysis preloads the explorer package
false&&require("persevere-client/explorer/explorer.js");
View
10 package.json
@@ -1,7 +1,7 @@
{
"name": "persevere-example-wiki",
"author": "",
- "version": "0.0.3",
+ "version": "0.0.4",
"contributors": [],
"mappings":{
"perstore": "http://github.com/kriszyp/perstore/zipball/v0.2.4!/",
@@ -26,10 +26,10 @@
}
],
"dependencies": {
- "pintura": ">=0.3.0",
- "perstore": ">=0.3.0",
- "promised-io": ">=0.3.0",
- "requirejs": ">=1.0.0",
+ "pintura": ">=0.3.1",
+ "perstore": ">=0.3.2",
+ "promised-io": ">=0.3.3",
+ "requirejs": ">=2.1.5",
"rql": ">=0.3.1",
"tunguska": ">=0.3.0",
"wiky": ">=0.95.1"
Please sign in to comment.
Something went wrong with that request. Please try again.