Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

34 lines (29 sloc) 1.776 kb
# -*- encoding: utf-8 -*-
require File.expand_path('../lib/rack/pack/version', __FILE__)
require 'bundler'
Gem::Specification.new do |s|
s.name = 'rack-pack'
s.version = Rack::Pack::VERSION
s.platform = Gem::Platform::RUBY
s.authors = ['Pete Browne']
s.email = ['me@petebrowne.com']
s.homepage = 'http://github.com/petebrowne/rack-pack'
s.summary = 'Rack Middleware for packaging assets such as javascripts and stylesheets.'
s.description = 'Rack::Pack is a piece of Rack Middleware that packages and optionally compresses assets such as javascripts and stylesheets into single files. In a development environment, assets will be packaged on each request if there have been changes to the source files. In a production environment, assets will only be packaged one time, and only if there have been changes.'
s.required_rubygems_version = '>= 1.3.6'
s.rubyforge_project = 'rack-pack'
s.add_dependency 'rack', '~> 1.2'
s.add_development_dependency 'rspec', '~> 2.6'
s.add_development_dependency 'activesupport', '~> 3.0'
s.add_development_dependency 'i18n', '~> 0.5'
s.add_development_dependency 'test-construct', '~> 1.2'
s.add_development_dependency 'jsmin', '~> 1.0'
s.add_development_dependency 'packr', '~> 3.1'
s.add_development_dependency 'yui-compressor', '~> 0.9'
s.add_development_dependency 'closure-compiler', '~> 0.3'
s.add_development_dependency 'uglifier', '~> 0.5'
s.add_development_dependency 'rainpress', '~> 1.0'
s.files = `git ls-files`.split("\n")
s.executables = `git ls-files`.split("\n").map{ |f| f =~ /^bin\/(.*)/ ? $1 : nil }.compact
s.require_path = 'lib'
end
Jump to Line
Something went wrong with that request. Please try again.