New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

HyRes does not work with StrictDI #14

Closed
XVincentX opened this Issue Jun 28, 2015 · 8 comments

Comments

Projects
None yet
2 participants
@XVincentX
Contributor

XVincentX commented Jun 28, 2015

When I enable strictDI option for my application, I am getting an error about your module.

screen shot 2015-06-28 at 12 26 43

Could you verify if everything is annotated properly?

@petejohanson petejohanson added the bug label Jun 28, 2015

@petejohanson

This comment has been minimized.

Owner

petejohanson commented Jul 6, 2015

Fixed in master. Will be included in the next release.

Thanks!

@XVincentX

This comment has been minimized.

Contributor

XVincentX commented Jul 6, 2015

Thanks! Looking forward for a new release then!

@petejohanson

This comment has been minimized.

Owner

petejohanson commented Jul 6, 2015

Give v0.0.25 a try.

@XVincentX

This comment has been minimized.

Contributor

XVincentX commented Jul 12, 2015

@petejohanson

After updating to 0.0.25 as well 0.0.26, I am getting this error when trying to execute an action specified in the resource.

I tried to update all my dependencies but still it does not work.

image

@petejohanson

This comment has been minimized.

Owner

petejohanson commented Jul 14, 2015

Very odd... I am gone for a week for a trip to someone's wedding, I will look at this as soon as I am back.

In the meantime, can you capture the properties of the Form instance that raises the error? In particular, it looks like this would only occur if the href propert of the Form instance isn't set. Looking at the response body of your client, it seems like the actions all havehref` set properly, so I'm curious what is going on here.

@XVincentX

This comment has been minimized.

Contributor

XVincentX commented Jul 20, 2015

@petejohanson I am afraid will be out for some days as well.
By the way, the bug is fully reproducible cloning this branch

Thanks, in meantime!

@petejohanson

This comment has been minimized.

Owner

petejohanson commented Jul 23, 2015

Please give new angular-hy-res@0.0.27 and hy-res@0.0.19 a try. We were not handling 201 Created responses from form submissions if they didn't include a Location header. We now gracefully fall back to previous behaviour in that case.

@XVincentX

This comment has been minimized.

Contributor

XVincentX commented Jul 24, 2015

Solved. Thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment