`require': cannot load such file -- inline (LoadError) #323

Closed
dblock opened this Issue Jan 25, 2013 · 3 comments

4 participants

@dblock

Dalli now requires RubyInline? I think the intention was to make this optional, but it's not.

/Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:251:in `require': cannot load such file -- inline (LoadError)
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:251:in `block in require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:236:in `load_dependency'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:251:in `require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/dalli-2.6.1/lib/dalli/ring.rb:78:in `<class:Ring>'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/dalli-2.6.1/lib/dalli/ring.rb:5:in `<module:Dalli>'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/dalli-2.6.1/lib/dalli/ring.rb:4:in `<top (required)>'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:251:in `require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:251:in `block in require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:236:in `load_dependency'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.11/lib/active_support/dependencies.rb:251:in `require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/dalli-2.6.1/lib/dalli.rb:3:in `<top (required)>'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:68:in `require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:68:in `block (2 levels) in require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:66:in `each'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:66:in `block in require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:55:in `each'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler/runtime.rb:55:in `require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.3/lib/bundler.rb:128:in `require'
    from /Users/dblock/source/gravity/dblock2/config/application.rb:8:in `<top (required)>'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.11/lib/rails/commands.rb:53:in `require'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.11/lib/rails/commands.rb:53:in `block in <top (required)>'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.11/lib/rails/commands.rb:50:in `tap'
    from /Users/dblock/.rvm/gems/ruby-1.9.3-p194/gems/railties-3.2.11/lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:5:in `require'
    from script/rails:5:in `<main>'

It's not in the gemspec requirements.

@carlosantoniodasilva

Just noticed this and made a comment in the related commit, it should probably rescue from LoadError in that case.

@jroes

This should be fixed in 2.6.2 based on commit comments from @carlosantoniodasilva above.

@mperham mperham closed this May 27, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment