Pre-release

3.0b1

@takluyver takluyver released this Oct 2, 2013 · 669 commits to master since this release

The new major version number doesn’t indicate any deliberate API incompatibility. We have endeavoured to avoid breaking existing APIs. However, pexpect is under new maintenance after a long dormancy, so some caution is warranted.

  • A new unicode API was introduced.
  • Python 3 is now supported, using a single codebase.
  • Pexpect now requires at least Python 2.6 or 3.2.

We also now have docs on ReadTheDocs, and continuous integration on Travis CI.

Downloads