Skip to content
Permalink
Browse files

remove failing tests for PostgreSQL version 8.3 add in tests for 11

* test version 11 over jdk8, 9, 10
  • Loading branch information...
davecramer committed Aug 30, 2019
1 parent ba82948 commit 89464a54777b9272893ab24bc5e28a24623e41bb
Showing with 32 additions and 19 deletions.
  1. +31 −18 .travis.yml
  2. +1 −1 codecov.yml
@@ -39,6 +39,7 @@ before_script:
- if [[ $TRAVIS_BRANCH == release/* ]]; then echo "MAVEN_OPTS='-Xmx1g'" > ~/.mavenrc; else echo "MAVEN_OPTS='-Xmx1g -Dgpg.skip=true'" > ~/.mavenrc; fi
- test "x$PG_VERSION" == 'x' || test "x$NO_HSTORE" == 'xY' || psql test -c 'CREATE EXTENSION hstore;' -U postgres
- test "x$PG_VERSION" == 'x' || test "x$CREATE_PLPGSQL" == 'x' || createlang -U postgres plpgsql test
- test "x$PG_VERSION" == 'x' || test "x$PLPGSQL_EXTENSION" == 'x' || psql test -c 'CREATE EXTENSION IF NOT EXISTS plpgsql;' -U postgres

env:
global:
@@ -102,6 +103,36 @@ matrix:
- PG_VERSION=10
- JDK=12
- TZ=America/New_York # flips between −05:00 and −04:00
- jdk: openjdk-ea
sudo: required
addons:
postgresql: "11"
env:
- PG_VERSION=11
- XA=true
- COVERAGE=Y
- NO_HSTORE=Y
- PLPGSQL_EXTENSION=Y
- jdk: oraclejdk9
sudo: required
addons:
postgresql: "11"
env:
- PG_VERSION=11
- XA=true
- COVERAGE=Y
- NO_HSTORE=Y
- PLPGSQL_EXTENSION=Y
- jdk: oraclejdk8
sudo: required
addons:
postgresql: "11"
env:
- PG_VERSION=11
- XA=true
- COVERAGE=Y
- NO_HSTORE=Y
- PLPGSQL_EXTENSION=Y
- jdk: oraclejdk11
sudo: required
addons:
@@ -188,24 +219,6 @@ matrix:
- COVERAGE=Y
- NO_HSTORE=Y
- CREATE_PLPGSQL=Y
- jdk: oraclejdk8
sudo: required
dist: precise
env:
- PG_VERSION=8.3
- XA=true
- COVERAGE=Y
- NO_HSTORE=Y
- CREATE_PLPGSQL=Y
- jdk: oraclejdk8
sudo: required
dist: precise
env:
- PG_VERSION=8.2
- XA=true
- COVERAGE=Y
- NO_HSTORE=Y
- CREATE_PLPGSQL=Y
- jdk: oraclejdk8
addons:
postgresql: "9.6"
@@ -1,6 +1,6 @@
codecov:
notify:
after_n_builds: 10
after_n_builds: 11
require_ci_to_pass: false
comment:
layout: header, changes, diff

0 comments on commit 89464a5

Please sign in to comment.
You can’t perform that action at this time.