Install

pgte edited this page Sep 13, 2010 · 3 revisions

Gem Depencies

install eventmachine gem

sudo gem install eventmachine

install choice gem

sudo gem install choice

install tokyocabinet

Note: You just need to install tokyocabinet if you are using Persistence

  1. On ubuntu/debian
  2. On MacOS

You don’t need to install TokyoTyrant. Only need install tokyocabinet and ruby bindings.

install sweepy

On your rails root do:

script/plugin install git://github.com/pgte/sweepy.git

set file file store cache on Rails

Edit config/environment.rb and place, before end:

config.cache_store = :file_store, File.join(RAILS_ROOT, 'tmp', '/cache')

This will tell Ruby to use file store cache and to place cache files under tmp/cache

» Configure
» Start Daemon