🦆 StrongSwan based VPN Controller for Kubernetes
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github
cmds
docs
hack
lib
vendor
.gitignore
.travis.yml
CONTRIBUTING.md
DCO
LICENSE
README.md
glide-slow
glide.lock
glide.yaml
main.go
version.go

README.md

Go Report Card Build Status codecov Docker Pulls Slack Twitter

SwanC

StrongSwan based VPN Controller for Kubernetes. This is intended to be used with Pharmer by AppsCode.

Supported Versions

Kubernetes 1.8+

Installation

To install Swanc, please follow the guide here.

Contribution guidelines

Want to help improve Swanc? Please start here.

Versioning Policy

Swanc does not follow semver, rather the major version of operator points to the Kubernetes client-go version. You can verify this from the glide.yaml file. This means there might be breaking changes between point releases of the operator.

Acknowledgement

Support

If you have any questions, file an issue or talk to us on the Kubernetes Slack team channel #pharmer.


The swanc operator collects anonymous usage statistics to help us learn how the software is being used and how we can improve it. To disable stats collection, run the operator with the flag --analytics=false.