Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

ensure_gem("terraform") doesn't play well with Bundler #9

Open
cespare opened this Issue · 0 comments

1 participant

@cespare
Collaborator

In the Barkeep deploy, we use ensure_gem("terraform") before running bundle install. This breaks every time the version of Terraform bumps, because the version of terraform loaded won't match the version in the Gemfile.

Perhaps this will be fixed with a more reasonable terraform loading system (we load terraform from about 3 different places in the Barkeep configuration, sometimes from bundler, sometimes from the written-out DSL file, sometimes via ensure_gem). I think we need a better example terraform deployment than Barkeep.

I suspect that you never want to have ensure_gem("terraform") -- I think that you should either require the DSL file, or load it via Bundler.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.