Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

F started to act like f recently #658

Closed
campugnatus opened this Issue · 17 comments

5 participants

campugnatus johnwchrome hyh1048576 Naemy Jez Ng
campugnatus

I'm not sure if it is related to the fresh version or to my recent Chrome reinstall, but currently I've got "F" and "a-f" hotkeys acting exactly like normal "f", that is they open selected link in the current tab.

I use Chrome v 21.0.1180.89 on Debian squeeze.

johnwchrome

I have this problem too
21.0.1180.89 (154005) on OpenBSD

hyh1048576

I don't have this problem. 21.0.1180.89 on a Mac OS X 10.7.4

campugnatus

It turned out that I have this problem in Windows 7 either. So it seems to be not so OS dependant.

johnwchrome

The funny thing is,
I have not this problem on my debian 21.0.1180.89 Debian wheezy/sid (154005),
but have this problem on openbsd 21.0.1180.89 (154005),
and I tried to remove(rm -rf) ~/.config/chromium on openbsd,
then only install vimium by default setting,
but still have this problem.
Any idea to find out what's go on?

johnwchrome

Shift-f also not work correct, it open link with current tab, not new tab.
Please help, thank you.

johnwchrome

Hi, I want download the old version(<1.37) for testing,
where can I download the binary files?

Naemy

I have this problem too, on a Mac OS X 10.7.5. :/

Edit : It works, if instead of typing F or f, I type the letters that follows either capital or minuscule.

Jez Ng
Collaborator

Hi guys, could you go here, press f and <a-f>, and copy-paste your result here? Remember to disable Vimium and copy with the mouse (otherwise the keypress data will get overwritten).

johnwchrome
Jez Ng
Collaborator

Hmm, that doesn't look out of the ordinary. Actually, I'm beginning to suspect that this is the same issue as #657, which I've just fixed. Do you mind trying out a copy of the development version (by cloning the master branch) and seeing if the problem has been resolved?

johnwchrome
johnwchrome
Jez Ng
Collaborator

@johnwchrome all past versions are available here: https://github.com/philc/vimium/downloads

johnwchrome

I found out what break the "F, O, <a-f>" feature.
I have --user-agent parameter, then I remove it, those feature work as expect now.
Thank all.

Jez Ng
Collaborator

Huh, that sounds really strange, but I'm glad you managed to triage it. I'm going to close this in the hopes that either your parameter change or the changes in the latest version will fix it for the rest of the commenters in this thread. Feel free to reopen if the issue still occurs.

Jez Ng int3 closed this
johnwchrome
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.