Permalink
Browse files

Don't try to load the FSEvents listener on older versions of OSX that…

… don't support it.
  • Loading branch information...
1 parent 15c4936 commit bb534668b6f52caf63725c9ef8798ee76e449e8a @philomory committed Feb 6, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 lib/guard/listeners/darwin.rb
@@ -30,7 +30,7 @@ def stop
# @return [Boolean] whether usable or not
#
def self.usable?(no_vendor = false)
- return false unless RbConfig::CONFIG['target_os'] =~ /darwin/i
+ return false unless RbConfig::CONFIG['target_os'] =~ /darwin(9|1\d)/i
$LOAD_PATH << File.expand_path('../../../vendor/darwin/lib', __FILE__) unless no_vendor
require 'rb-fsevent'

0 comments on commit bb53466

Please sign in to comment.