Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
79 lines (78 sloc) 2.4 KB
{
"name": "gh-board",
"version": "0.0.0",
"description": "kanban board using just GitHub",
"main": "index.js",
"scripts": {
"lint": "eslint src --ext .js --ext .jsx",
"start": "webpack-dev-server --progress --colors --display-chunks --display-modules --display-origins",
"build": "npm run lint; NODE_ENV=production webpack --optimize-minimize --progress --colors",
"dev-build": "npm run lint; webpack --progress --colors",
"start-webdriver": "webdriver-manager update && webdriver-manager start",
"test:only": "ava --verbose --serial",
"test": "./script/run-test.sh",
"deploy": "./script/deploy.sh"
},
"author": "Philip Schatz",
"license": "AGPL3.0",
"devDependencies": {
"ava": "^0.17.0",
"babel-core": "^6.3.17",
"babel-eslint": "^7.1.0",
"babel-loader": "^6.2.0",
"babel-preset-es2015": "^6.3.13",
"babel-preset-react": "^6.3.13",
"css-loader": "^0.26.1",
"eslint": "^3.8.1",
"eslint-loader": "^1.1.1",
"eslint-plugin-react": "^6.4.1",
"extract-text-webpack-plugin": "^1.0.1",
"favico.js": "^0.3.10",
"file-loader": "^0.9.0",
"http-server": "^0.9.0",
"json-loader": "^0.5.4",
"less": "^2.5.3",
"less-loader": "^2.2.2",
"node-libs-browser": "^2.0.0",
"parallelshell": "^2.0.0",
"react-hot-loader": "^3.0.0-beta.6",
"url-loader": "^0.5.6",
"webdriver-manager": "^11.1.0",
"webdriverio": "^4.5.2",
"webpack": "^1.9.10",
"webpack-dev-server": "^1.9.0"
},
"dependencies": {
"babel-polyfill": "^6.3.14",
"bootstrap": "^3.3.6",
"c3": "^0.4.11",
"classnames": "^2.2.1",
"d3": "^4.3.0",
"dexie": "^1.3.1",
"etherpad-lite-client": "philschatz/etherpad-lite-client-js#master",
"gfm-linkify": "^0.1.0",
"history": "^4.5.0",
"jsonquery-engine": "^1.0.2",
"level-js": "philschatz/level.js#master",
"level-queryengine": "^3.0.1",
"levelidb": "^0.2.6",
"levelup": "^1.3.1",
"memdown": "^1.1.2",
"mermaid": "^6.0.0",
"moment": "2.17.1",
"octicons": "^5.0.1",
"octokat": ">=0.5.0-beta.0",
"puzzle-script": "0.0.2",
"qs": "^6.3.0",
"react": "^15.3.2",
"react-bootstrap": "^0.30.5",
"react-dnd": "^2.1.2",
"react-dnd-html5-backend": "^2.1.2",
"react-dom": "^15.3.2",
"react-octicons": "0.0.4",
"react-router": "^3.0.0",
"recordo": "^0.0.6",
"ultramarked": "^1.7.0",
"underscore": "^1.8.3"
}
}