Permalink
Browse files

update default version to 9.2, add ssl attributes

  • Loading branch information...
1 parent ebdb88b commit af8ed63be3232cd4d66902170ed1aec479dc2bae @phlipper committed Dec 27, 2012
Showing with 7 additions and 3 deletions.
  1. +2 −2 README.md
  2. +5 −1 attributes/default.rb
View
@@ -12,7 +12,7 @@ Currently supported versions:
* `9.1`
* `9.2`
-The default version is `9.1`.
+The default version is `9.2`.
## Requirements
@@ -117,7 +117,7 @@ Or add the user/database via attributes:
## Attributes
```ruby
-default["postgresql"]["version"] = "9.1"
+default["postgresql"]["version"] = "9.2"
default["postgresql"]["environment_variables"] = {}
default["postgresql"]["pg_ctl_options"] = ""
View
@@ -7,7 +7,7 @@
# Copyright 2012, Phil Cohen
#
-default["postgresql"]["version"] = "9.1"
+default["postgresql"]["version"] = "9.2"
default["postgresql"]["environment_variables"] = {}
default["postgresql"]["pg_ctl_options"] = ""
@@ -50,6 +50,10 @@
default["postgresql"]["ssl"] = true
default["postgresql"]["ssl_ciphers"] = "ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH"
default["postgresql"]["ssl_renegotiation_limit"] = "512MB"
+default["postgresql"]["ssl_ca_file"] = ""
+default["postgresql"]["ssl_cert_file"] = "server.crt"
+default["postgresql"]["ssl_crl_file"] = ""
+default["postgresql"]["ssl_key_file"] = "server.key"
default["postgresql"]["password_encryption"] = "on"
default["postgresql"]["db_user_namespace"] = "off"

0 comments on commit af8ed63

Please sign in to comment.