New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

build fail on android #149

Closed
roysG opened this Issue Sep 16, 2015 · 3 comments

Comments

Projects
None yet
2 participants
@roysG

roysG commented Sep 16, 2015

info:

Your system information:

Cordova CLI: 5.3.1
Ionic Version: 1.1.0
Ionic CLI Version: 1.6.4
Ionic App Lib Version: 0.3.8
ios-deploy version: 1.7.0
ios-sim version: 5.0.1
OS: Mac OS X Yosemite
Node Version: v4.0.0
Xcode version: Xcode 6.3.2 Build version 6D2105

Error:

testApps/platforms/android/src/com/adobe/phonegap/push/GCMIntentService.java:398: cannot find symbol
symbol : method setColor(int)
location: class android.support.v4.app.NotificationCompat.Builder
mBuilder.setColor(iconColor);
^
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: /Users/Admin/www/picktags.com/public_html/testApps/platforms/android/src/com/adobe/phonegap/push/GCMIntentService.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
1 error
100 warnings
:compileDebugJava FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ':compileDebugJava'.

    Compilation failed; see the compiler error output for details.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

@roysG

This comment has been minimized.

Show comment
Hide comment
@roysG

roysG Sep 17, 2015

any updates?

roysG commented Sep 17, 2015

any updates?

@macdonst

This comment has been minimized.

Show comment
Hide comment
@macdonst

macdonst Sep 17, 2015

Member

@roysG your issue is a duplicate of #51 so I'm going to close it. There is info on how to work around it there. In short you have an older version of 'android-support-v13.jar' being picked up by your system. You may need to update it via the 'android' command.

Also, the 'master' branch has switched to using Gradle so this issue will go away during the next release.

Member

macdonst commented Sep 17, 2015

@roysG your issue is a duplicate of #51 so I'm going to close it. There is info on how to work around it there. In short you have an older version of 'android-support-v13.jar' being picked up by your system. You may need to update it via the 'android' command.

Also, the 'master' branch has switched to using Gradle so this issue will go away during the next release.

@macdonst macdonst closed this Sep 17, 2015

@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot Jun 5, 2018

This thread has been automatically locked.

lock bot commented Jun 5, 2018

This thread has been automatically locked.

@lock lock bot locked as resolved and limited conversation to collaborators Jun 5, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.