[Android] Analytics: Upgraded to support Version 2 of the Analytics SDK #882

Closed
wants to merge 11 commits into from

6 participants

@sathvikp

NOV, 14, 2012

  • Upgraded to support Version 2 of the Google Analytics SDK
  • Added the stop method
  • Set it to use EasyTracker
  • Removed Support for setCustomVar as the SDK no longer supports it

https://developers.google.com/analytics/devguides/collection/android/v2/migration

Should Close: #881, #483, #874, #758

@sathvikp

@RandyMcMillan How does one use a label on a pull-request?
And why exactly did you close this, it's not just because of the label, is it?

@devgeeks devgeeks reopened this Nov 26, 2012
@devgeeks
PhoneGap member

Another one too Android-y for me feel comfortable merging...

@macdonst ?

@robdiciuccio

Looks like the GA Android SDK 2.0 is still in beta. Perhaps this should be a new version (2.2) of the plugin, for those of us who still need setCustomVar?

@sathvikp

@robdiciuccio Yes, it is still in beta, but the issue is that Google is no longer accepting data from the older SDK version, so we are forced to upgrade.

https://developers.google.com/analytics/devguides/collection/android/v2/migration :

With the release of the new Google Analytics Mobile App Analytics reports for Android , we've also introduced a new app profile type and a new set of app reports to designed specifically for analyzing your app usage data. Keep in mind that new app profiles and reports will only accept data from version 2 or higher of the SDK. See our Account Configuration Best Practices to learn more.

Are you still able to use GA with an older SDK?

@muszek

I can confirm that with a newly created profile sathvikp's code works and the official repo's does not.

@robdiciuccio

I am currently using GA SDK v1.5.1 successfully (with an existing profile) on Cordova 2.2.0. Why not make this a new version of the plugin, so both can coexist?

@sathvikp

Changes:

@shazron
PhoneGap member

This repo has been deprecated and will not be actively maintained - no pull requests nor any other issues will be worked on. The previous source currently exists in the DEPRECATED branch, and may be removed at a future date.
Migration path, see: https://github.com/phonegap/phonegap-plugins/blob/master/README.md

@shazron shazron closed this Nov 4, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment