Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Metadata: Set altitude even if coordinates are missing #1749

Closed
hjed opened this issue Nov 22, 2021 · 2 comments
Closed

Metadata: Set altitude even if coordinates are missing #1749

hjed opened this issue Nov 22, 2021 · 2 comments
Assignees
Labels
bug Something isn't working released Available in the stable release

Comments

@hjed
Copy link

hjed commented Nov 22, 2021

What does not work as expected?

GPS Location parsing fails with the message metadata: failed parsing GPS coordinates in IMG_20170611_183659.jpg (exif) for images that only have the "GPS Altitude Reference" set in the GPS data and no actual co-ordinates. Apparently my old OnePlus 3t did this on quite a lot of photos.

Note this isn't a massive issue as it doesn't appear to break anything that I can work out.

How can we reproduce it?

Try and index the attached image:
IMG_20170611_183659

What behavior do you expect?

It shouldn't try and index GPS data from this image and doesn't need to log an error.

Can you provide us with example files for testing or screenshots?

IMG_20170611_183659

I can provide other examples if needed but they all look pretty similar

What version you are using?

211018-e200f322-Linux-armv7l

@hjed hjed added the bug Something isn't working label Nov 22, 2021
@lastzero lastzero self-assigned this Nov 24, 2021
@lastzero lastzero changed the title Bug: Handle Only Altitude being set Metadata: Set altitude even if coordinates are missing Nov 24, 2021
@lastzero lastzero added the please-test Ready for acceptance test label Nov 24, 2021
@graciousgrey graciousgrey added released Available in the stable release and removed please-test Ready for acceptance test labels Nov 29, 2021
@hjed
Copy link
Author

hjed commented Dec 13, 2021

Hey I'm still seeing similar errors - not exactly the same thing so happy to open a new bug but I think the cause is likely the same error (GPS data present but not lat/long) - Here's an example image
DSCN7980

@graciousgrey
Copy link
Member

@hjed I tested with this file. It does not contain GPS information in it's exif data

exiftool -j yourfile.jpeg | grep GPS shows

"GPSVersionID": "2.3.0.0", "GPSImgDirectionRef": "Magnetic North", "GPSImgDirection": "undef",

that's why there is no lat/lng set.
I also do not get an error when indexing this file.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something isn't working released Available in the stable release
Projects
Status: Release 🌈
Development

No branches or pull requests

3 participants