New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update documentation for PSR-16 compatibility. #99

Open
ndobromirov opened this Issue Mar 23, 2017 · 1 comment

Comments

Projects
None yet
3 participants
@ndobromirov

ndobromirov commented Mar 23, 2017

Everywhere it is stated that the extension is PSR-6 compatible. This is hinting that people will have to write adapters for PSR-16 clients.

It turned out that the API is both PSR-6 and PSR-16 compliant on AbstractCachePool level, so all of the drivers should support both by default. As it already implements the Psr\SimpleCache\CacheInterface.

Shouldn't the docks be updated to reflect the fact?

@Nyholm

This comment has been minimized.

Show comment
Hide comment
@Nyholm

Nyholm Mar 23, 2017

Member

Yes, it should. Thank you for creating the issue.

Member

Nyholm commented Mar 23, 2017

Yes, it should. Thank you for creating the issue.

@prisis prisis added the Docs label Mar 23, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment