Skip to content
Permalink
master
Go to file
 
 
Cannot retrieve contributors at this time
128 lines (123 sloc) 4.17 KB
{
"name": "php-censor/php-censor",
"description": "PHP Censor is a open source self-hosted continuous integration server for PHP projects (PHPCI fork).",
"minimum-stability": "stable",
"type": "application",
"keywords": [
"php",
"php-censor",
"phpci",
"ci-server",
"testing",
"self-hosted",
"open-source",
"ci",
"continuous integration"
],
"homepage": "http://php-censor.info",
"license": "BSD-2-Clause",
"authors": [
{
"name": "Dmitry Khomutov",
"email": "poisoncorpsee@gmail.com",
"homepage": "http://corpsee.com",
"role": "PHP Censor developer"
},
{
"name": "Dan Cryer",
"email": "dan.cryer@block8.co.uk",
"homepage": "http://www.block8.co.uk",
"role": "PHPCI developer"
}
],
"support": {
"issues": "https://github.com/php-censor/php-censor/issues",
"source": "https://github.com/php-censor/php-censor"
},
"autoload": {
"psr-4": {
"PHPCensor\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
"Tests\\PHPCensor\\": "tests/src/"
}
},
"require": {
"php": ">=7.1.0",
"ext-openssl": "*",
"ext-PDO": "*",
"ext-json": "*",
"ext-dom": "*",
"ext-libxml": "*",
"ext-SimpleXML": "*",
"ext-curl": "*",
"ext-bcmath": "*",
"swiftmailer/swiftmailer": "^6.1",
"symfony/yaml": "^4.2",
"symfony/http-foundation": "^4.2",
"symfony/console": "^4.2",
"symfony/finder": "^4.2",
"symfony/dom-crawler": "^4.2",
"symfony/css-selector": "^4.2",
"symfony/browser-kit": "^4.2",
"symfony/process": "^4.2",
"symfony/filesystem": "^4.2",
"symfony/dependency-injection": "^4.2",
"symfony/event-dispatcher": "^4.2",
"symfony/cache": "^4.2",
"psr/log": "^1.1",
"monolog/monolog": "^1.24",
"pimple/pimple": "^3.2",
"robmorgan/phinx": "~0.11.0",
"sensiolabs/ansi-to-html": "^1.1",
"pda/pheanstalk": "^3.2",
"guzzlehttp/guzzle": "^6.3",
"jasongrimes/paginator": "^1.0",
"voku/anti-xss": "^4.1",
"maknz/slack": "^1.7",
"hipchat/hipchat-php": "^1.4",
"php-censor/flowdock-client": "^1.0",
"npm-asset/sprintf-js": "^1.0",
"npm-asset/codemirror": "^5.23",
"bower-asset/admin-lte": "^2.3",
"bower-asset/font-awesome": "^4.7",
"bower-asset/ionicons": "^2.0",
"bower-asset/raphael": "^2.2",
"oomphinc/composer-installers-extender": "^1.1"
},
"require-dev": {
"phpunit/phpunit": "^7.5",
"squizlabs/php_codesniffer": "^3.4",
"sebastian/phpcpd": "^4.1",
"phploc/phploc": "^4.0",
"phpmd/phpmd": "^2.6",
"php-parallel-lint/php-parallel-lint": "^1.0",
"sensiolabs/security-checker": "^6.0",
"php-censor/phpdoc-checker": "^2.0",
"friendsofphp/php-cs-fixer": "^2.15",
"symfony/var-dumper": "^4.2"
},
"extra": {
"platform": {
"php": "7.1.*"
},
"installer-types": [
"bower-asset",
"npm-asset"
],
"installer-paths": {
"public/assets/vendor/{$name}/": [
"type:bower-asset",
"type:npm-asset"
]
}
},
"repositories": [
{
"type": "composer",
"url": "https://asset-packagist.org"
}
]
}
You can’t perform that action at this time.