Permalink
Browse files

Added roadmap for the next versions of PHP Censor (ROADMAP.md).

  • Loading branch information...
corpsee committed Jan 12, 2019
1 parent 55f8ded commit f1fac7c7940e75ac88b3704b2519571fe6fab968
Showing with 51 additions and 1 deletion.
  1. +1 −1 CHANGELOG.md
  2. +10 −0 README.md
  3. +40 −0 ROADMAP.md
@@ -1,4 +1,4 @@
# Change Log
# Changelog


The format is based on [Keep a Changelog](http://keepachangelog.com/en/1.0.0/) and this project adheres to
@@ -23,6 +23,8 @@ More [screenshots](docs/en/screenshots.md).

* [System requirements](#system-requirements)
* [Features](#features)
* [Changelog](#changelog)
* [Roadmap](#roadmap)
* [Installing](#installing)
* [Installing via Docker](#installing-via-docker)
* [Updating](#updating)
@@ -68,6 +70,14 @@ CleanBuild, CopyBuild, Deployer, Env, Git, Grunt, Gulp, PackageBuild, Phar, Phin

* Use your LDAP-server for authentication;

## Changelog

[Versions changelog](ROADMAP.md).

## Roadmap

[PHP Censor roadmap](ROADMAP.md).

## Installing

* Go to the directory in which you want to install PHP Censor, for example: `/var/www`:
@@ -0,0 +1,40 @@
# Roadmap

## Version 1.0

Version `1.0` is the current major stable version. This version will include bug fixes only (Versions `1.0.1`,
`1.0.2` etc.). See [the full list of issues](https://github.com/php-censor/php-censor/milestone/1) are planed for version
`1.0`.

## Version 1.x

Version `1` will probably have a few minor versions (`1.1.x`, `1.2.x` etc.) with some backward compatible changes and
features. See [the full list of issues](https://github.com/php-censor/php-censor/milestone/2) for minor versions.

## Version 2.0

Version `2.0` is the next stable major version with some backward incompatible features and changes like:

* Remove deprecated features.
* Upgrade minimal PHP version to `7.1`.
* Move plugins to optional Composer packages.
* Use Npm (Yarn) and Webpack for css/js assets instead of Composer.
* Make special plugin type for sources (Local, Git, Github, Hg etc.).

You can see more planed features for version `2.0` in the
[full list of issues](https://github.com/php-censor/php-censor/milestone/3).

## Version 2.x

Version `2` will probably have a few minor versions (`2.1.x`, `2.2.x` etc.) with some backward compatible changes and
features. See [full list of issues](https://github.com/php-censor/php-censor/milestone/2) for minor versions.

## Major version after 2.0

Also we have some big backward incompatible features for next major releases (`3.0`, `4.0` etc.):

* Move to Symfony4 framework.
* Move to Vue.js framework for javascript part.

You can see more planed features for future major versions in the
[full list of issues](https://github.com/php-censor/php-censor/milestone/4).

0 comments on commit f1fac7c

Please sign in to comment.