Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tag: php-4.3.3
Fetching contributors…

Cannot retrieve contributors at this time

file 72 lines (61 sloc) 2.054 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72
#! /bin/sh

prefix='@prefix@'
phpdir="$prefix/lib/php/build"
includedir="$prefix/include/php"
builddir="`pwd`"

FILES_BUILD="mkdep.awk shtool"
FILES="acinclude.m4 Makefile.global scan_makefile_in.awk"
CLEAN_FILES="$FILES *.lo *.la *.o .deps .libs/ build/ include/ modules/ install-sh \
    mkinstalldirs missing config.nice config.sub config.guess configure configure.in \
aclocal.m4 config.h config.h.in conftest* ltmain.sh libtool config.cache \
config.log config.status Makefile Makefile.fragments Makefile.objects"

case "$1" in
  # Cleanup
  --clean)
    if test -r config.m4; then
      echo "Cleaning.."
      for i in $CLEAN_FILES; do
        test -e $i && rm -rf $i
      done
      exit 0
    else
      echo "Cannot find config.m4. "
      echo "Make sure that you run '$0 --clean' in the top level source directory of the module"
      echo
      exit 1
    fi
    ;;
  # Usage
  --help)
    echo "Usage: $0 [--clean|--help]"
    exit 1
    ;;
  *)
    if test ! -r config.m4; then
      echo "Cannot find config.m4. "
      echo "Make sure that you run '$0' in the top level source directory of the module"
      echo
      exit 1
    fi
    ;;
esac

test -d build || mkdir build

(cd $phpdir && cp $FILES_BUILD "$builddir"/build)
(cd $phpdir && cp $FILES "$builddir")

sed \
-e "s#@prefix@#$prefix#" \
< $phpdir/phpize.m4 > configure.in

touch install-sh mkinstalldirs missing

aclocal || exit 1
autoconf || exit 1
autoheader || exit 1
libtoolize -f -c || exit 1

# dumping API NOs:
PHP_API_VERSION=`egrep '#define PHP_API_VERSION' $includedir/main/php.h|sed 's/#define PHP_API_VERSION//'`
ZEND_MODULE_API_NO=`egrep '#define ZEND_MODULE_API_NO' $includedir/Zend/zend_modules.h|sed 's/#define ZEND_MODULE_API_NO//'`
ZEND_EXTENSION_API_NO=`egrep '#define ZEND_EXTENSION_API_NO' $includedir/Zend/zend_extensions.h|sed 's/#define ZEND_EXTENSION_API_NO//'`

echo "Configuring for:"
echo " PHP Api Version: "$PHP_API_VERSION
echo " Zend Module Api No: "$ZEND_MODULE_API_NO
echo " Zend Extension Api No: "$ZEND_EXTENSION_API_NO

exit 0
Something went wrong with that request. Please try again.