Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge branch 'PHP-5.3' into PHP-5.4

* PHP-5.3:
  add unit test for bug 63126
  NEWS
  • Loading branch information...
commit 88d2b8c5fd0ec4e85e84e6b76fe8660823a65273 2 parents 7cd2f4b + 9214724
@remicollet remicollet authored
Showing with 52 additions and 0 deletions.
  1. +52 −0 ext/imap/tests/bug63126.phpt
View
52 ext/imap/tests/bug63126.phpt
@@ -0,0 +1,52 @@
+--TEST--
+imap_open() DISABLE_AUTHENTICATOR ignores array param
+--SKIPIF--
+<?php
+extension_loaded('imap') or die('skip imap extension not available in this build');
+
+require_once(dirname(__FILE__).'/imap_include.inc');
+
+$in = imap_open($default_mailbox, $username, $password, OP_HALFOPEN, 1);
+if (!$in) {
+ die("skip could not connect to mailbox $default_mailbox");
+}
+$kerberos = false;
+if (is_array($errors = imap_errors())) {
+ foreach ($errors as $err) {
+ if (strstr($err, 'GSSAPI') || strstr($err, 'Kerberos')) {
+ $kerberos = true;
+ }
+ }
+}
+if (!$kerberos) {
+ die("skip need a GSSAPI/Kerberos aware server");
+}
+?>
+--FILE--
+<?php
+$tests = array(
+ 'Array' => array('DISABLE_AUTHENTICATOR' => array('GSSAPI','NTLM')),
+ 'String' => array('DISABLE_AUTHENTICATOR' => 'GSSAPI'),
+);
+require_once(dirname(__FILE__).'/imap_include.inc');
+foreach ($tests as $name => $testparams) {
+ echo "Test for $name\n";
+ $in = imap_open($default_mailbox, $username, $password, OP_HALFOPEN, 1, $testparams);
+ if ($in) {
+ if (is_array($errors = imap_errors())) {
+ foreach ($errors as $err) {
+ if (strstr($err, 'GSSAPI') || strstr($err, 'Kerberos')) {
+ echo "$err\n";
+ }
+ }
+ }
+ } else {
+ echo "Can't connect\n";
+ }
+}
+echo "Done\n";
+?>
+--EXPECTF--
+Test for Array
+Test for String
+Done
Please sign in to comment.
Something went wrong with that request. Please try again.