Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

- Unify the "configure --help" texts

  • Loading branch information...
commit a20383ba06c911615b8e95387fd3b016670f4ae8 1 parent d12196e
foobar authored
Showing with 160 additions and 180 deletions.
  1. +1 −1  TSRM/tsrm.m4
  2. +6 −6 Zend/Zend.m4
  3. +14 −14 configure.in
  4. +1 −1  ext/bcmath/config.m4
  5. +2 −2 ext/dba/config.m4
  6. +0 −2  ext/dbase/config.m4
  7. +2 −2 ext/dom/config.m4
  8. +1 −1  ext/fbsql/config.m4
  9. +1 −1  ext/fdf/config.m4
  10. +1 −1  ext/filepro/config.m4
  11. +8 −8 ext/gd/config.m4
  12. +1 −1  ext/gettext/config.m4
  13. +3 −3 ext/imap/config.m4
  14. +1 −1  ext/informix/config.m4
  15. +2 −2 ext/ldap/config.m4
  16. +2 −2 ext/libxml/config0.m4
  17. +1 −1  ext/mcrypt/config.m4
  18. +1 −4 ext/mcve/config.m4
  19. +1 −1  ext/mhash/config.m4
  20. +1 −1  ext/msql/config.m4
  21. +1 −1  ext/mssql/config.m4
  22. +5 −5 ext/mysql/config.m4
  23. +2 −2 ext/mysqli/config.m4
  24. +1 −1  ext/ncurses/config.m4
  25. +1 −1  ext/oci8/config.m4
  26. +11 −13 ext/odbc/config.m4
  27. +1 −1  ext/oracle/config.m4
  28. +1 −1  ext/ovrimos/config.m4
  29. +1 −1  ext/pdo/config.m4
  30. +2 −2 ext/pdo_firebird/config.m4
  31. +2 −2 ext/pdo_mysql/config.m4
  32. +4 −6 ext/pdo_oci/config.m4
  33. +18 −25 ext/pdo_odbc/config.m4
  34. +2 −3 ext/pdo_pgsql/config.m4
  35. +1 −1  ext/pdo_sqlite/config.m4
  36. +1 −1  ext/pfpro/config.m4
  37. +1 −1  ext/pgsql/config.m4
  38. +1 −1  ext/pspell/config.m4
  39. +2 −2 ext/readline/config.m4
  40. +1 −1  ext/recode/config.m4
  41. +1 −1  ext/session/config.m4
  42. +3 −4 ext/snmp/config.m4
  43. +1 −1  ext/soap/config.m4
  44. +2 −2 ext/sqlite/config.m4
  45. +1 −1  ext/standard/config.m4
  46. +1 −2  ext/sybase/config.m4
  47. +1 −1  ext/sybase_ct/config.m4
  48. +1 −1  ext/sysvsem/config.m4
  49. +1 −1  ext/sysvshm/config.m4
  50. +1 −1  ext/tidy/config.m4
  51. +1 −1  ext/wddx/config.m4
  52. +1 −1  ext/xml/config.m4
  53. +1 −1  ext/xmlreader/config.m4
  54. +3 −3 ext/xmlrpc/config.m4
  55. +1 −1  ext/xsl/config.m4
  56. +1 −1  ext/zlib/config0.m4
  57. +3 −3 sapi/apache/config.m4
  58. +2 −2 sapi/apache2filter/config.m4
  59. +3 −3 sapi/apache2handler/config.m4
  60. +3 −3 sapi/apache_hooks/config.m4
  61. +2 −3 sapi/caudium/config.m4
  62. +11 −12 sapi/cgi/config9.m4
  63. +1 −1  sapi/cli/config.m4
  64. +2 −1  sapi/continuity/config.m4
  65. +1 −1  sapi/isapi/config.m4
  66. +2 −2 sapi/roxen/config.m4
2  TSRM/tsrm.m4
View
@@ -96,7 +96,7 @@ dnl to maintain consistency
AC_ARG_WITH(tsrm-pth,
[ --with-tsrm-pth[=pth-config]
- Use GNU Pth.],[
+ Use GNU Pth],[
TSRM_PTH=$withval
],[
TSRM_PTH=no
12 Zend/Zend.m4
View
@@ -122,8 +122,8 @@ AC_ARG_ENABLE(debug,
AC_DEFUN([LIBZEND_OTHER_CHECKS],[
PHP_ARG_WITH(zend-vm,[virtual machine dispatch method],
-[ --with-zend-vm=TYPE Sets virtual machine dispatch methos. Type is
- one of "CALL" (default), "SWITCH" or "GOTO"], CALL, no)
+[ --with-zend-vm=TYPE Set virtual machine dispatch method. Type is
+ one of "CALL", "SWITCH" or "GOTO" [TYPE=CALL]], CALL, no)
case $PHP_ZEND_VM in
SWITCH)
@@ -138,7 +138,7 @@ case $PHP_ZEND_VM in
esac
AC_ARG_ENABLE(maintainer-zts,
-[ --enable-maintainer-zts Enable thread safety - for code maintainers only],[
+[ --enable-maintainer-zts Enable thread safety - for code maintainers only!!],[
ZEND_MAINTAINER_ZTS=$enableval
],[
ZEND_MAINTAINER_ZTS=no
@@ -146,21 +146,21 @@ AC_ARG_ENABLE(maintainer-zts,
AC_ARG_ENABLE(inline-optimization,
[ --disable-inline-optimization
- If building zend_execute.lo fails, try this switch.],[
+ If building zend_execute.lo fails, try this switch],[
ZEND_INLINE_OPTIMIZATION=$enableval
],[
ZEND_INLINE_OPTIMIZATION=yes
])
AC_ARG_ENABLE(memory-limit,
-[ --enable-memory-limit Compile with memory limit support. ], [
+[ --enable-memory-limit Compile with memory limit support], [
ZEND_MEMORY_LIMIT=$enableval
],[
ZEND_MEMORY_LIMIT=no
])
AC_ARG_ENABLE(zend-multibyte,
-[ --enable-zend-multibyte Compile with zend multibyte support. ], [
+[ --enable-zend-multibyte Compile with zend multibyte support], [
ZEND_MULTIBYTE=$enableval
],[
ZEND_MULTIBYTE=no
28 configure.in
View
@@ -602,7 +602,7 @@ PHP_CONFIGURE_PART(General settings)
PHP_HELP_SEPARATOR([General settings:])
PHP_ARG_ENABLE(debug, whether to include debugging symbols,
-[ --enable-debug Compile with debugging symbols.], no, no)
+[ --enable-debug Compile with debugging symbols], no, no)
if test "$PHP_DEBUG" = "yes"; then
PHP_DEBUG=1
@@ -613,8 +613,8 @@ else
fi
PHP_ARG_WITH(layout,[layout of installed files],
-[ --with-layout=TYPE Sets how installed files will be laid out. Type is
- one of "PHP" (default) or "GNU"], PHP, no)
+[ --with-layout=TYPE Set how installed files will be laid out. Type is
+ one of "PHP" or "GNU" [TYPE=PHP]], PHP, no)
case $PHP_LAYOUT in
GNU)
@@ -626,9 +626,9 @@ case $PHP_LAYOUT in
esac
PHP_ARG_WITH(config-file-path,[path to configuration file],
-[ --with-config-file-path=PATH
- Sets the path in which to look for php.ini,
- defaults to PREFIX/lib], DEFAULT, no)
+[ --with-config-file-path=PATH
+ Set the path in which to look for php.ini
+ [PREFIX/lib]], DEFAULT, no)
if test "$PHP_CONFIG_FILE_PATH" = "DEFAULT"; then
case $PHP_LAYOUT in
@@ -650,7 +650,7 @@ fi
test -n "$DEBUG_CFLAGS" && CFLAGS="$CFLAGS $DEBUG_CFLAGS"
PHP_ARG_ENABLE(safe-mode, whether to enable safe mode by default,
-[ --enable-safe-mode Enable safe mode by default.], no, no)
+[ --enable-safe-mode Enable safe mode by default], no, no)
if test "$PHP_SAFE_MODE" = "yes"; then
AC_DEFINE(PHP_SAFE_MODE,1,[ ])
@@ -660,8 +660,8 @@ fi
AC_MSG_CHECKING([for safe mode exec dir])
AC_ARG_WITH(exec-dir,
-[ --with-exec-dir[=DIR] Only allow executables in DIR when in safe mode
- defaults to /usr/local/php/bin],
+[ --with-exec-dir[=DIR] Only allow executables in DIR under safe-mode
+ [/usr/local/php/bin]],
[
if test "$withval" != "no"; then
if test "$withval" = "yes"; then
@@ -681,7 +681,7 @@ AC_ARG_WITH(exec-dir,
])
PHP_ARG_ENABLE(sigchild,whether to enable PHP's own SIGCHLD handler,
-[ --enable-sigchild Enable PHP's own SIGCHLD handler.], no, no)
+[ --enable-sigchild Enable PHP's own SIGCHLD handler], no, no)
if test "$PHP_SIGCHILD" = "yes"; then
AC_DEFINE(PHP_SIGCHILD, 1, [ ])
@@ -715,7 +715,7 @@ if test "$PHP_LIBGCC" = "yes"; then
fi
PHP_ARG_ENABLE(short-tags,whether to enable short tags by default,
-[ --disable-short-tags Disable the short-form <? start tag by default.],yes, no)
+[ --disable-short-tags Disable the short-form <? start tag by default],yes, no)
if test "$PHP_SHORT_TAGS" = "yes"; then
AC_DEFINE(DEFAULT_SHORT_OPEN_TAG,"1",[ ])
@@ -794,7 +794,7 @@ dnl Check if all enabled by default extensions should be disabled
dnl
AC_ARG_ENABLE(all,
-[ --disable-all Disable all extensions enabled by default.
+[ --disable-all Disable all extensions which are enabled by default
], [
PHP_ENABLE_ALL=$enableval
])
@@ -862,7 +862,7 @@ if test "$PHP_SAPI_CLI" = "no"; then
fi
PHP_ARG_WITH(pear, [whether to install PEAR],
-[ --with-pear=DIR Install PEAR in DIR (default PREFIX/lib/php)
+[ --with-pear=DIR Install PEAR in DIR [PREFIX/lib/php]
--without-pear Do not install PEAR], DEFAULT, yes)
if test "$PHP_PEAR" != "no"; then
@@ -976,7 +976,7 @@ datadir=`eval echo $datadir`
dnl Build extension directory path
-ZEND_MODULE_API_NO=`egrep '#define ZEND_MODULE_API_NO ' $srcdir/Zend/zend_modules.h|sed 's/#define ZEND_MODULE_API_NO //'`
+ZEND_MODULE_API_NO=`$EGREP '#define ZEND_MODULE_API_NO ' $srcdir/Zend/zend_modules.h|$SED 's/#define ZEND_MODULE_API_NO //'`
if test -z "$EXTENSION_DIR"; then
extbasedir=$ZEND_MODULE_API_NO
2  ext/bcmath/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(bcmath, whether to enable bc style precision math functions,
-[ --enable-bcmath Enable bc style precision math functions.])
+[ --enable-bcmath Enable bc style precision math functions])
if test "$PHP_BCMATH" != "no"; then
PHP_NEW_EXTENSION(bcmath, bcmath.c \
4 ext/dba/config.m4
View
@@ -505,7 +505,7 @@ AC_DEFUN([PHP_DBA_BUILTIN_INI],[
])
AC_ARG_WITH(inifile,
-[ --with-inifile DBA: Include INI support],[
+[ --with-inifile DBA: Include INI support],[
if test "$withval" != "no"; then
PHP_DBA_BUILTIN_INI
fi
@@ -526,7 +526,7 @@ dnl
dnl FlatFile check must be the last one.
dnl
AC_ARG_WITH(flatfile,
-[ --with-flatfile DBA: Include FlatFile support],[
+[ --with-flatfile DBA: Include FlatFile support],[
if test "$withval" != "no"; then
PHP_DBA_BUILTIN_FLATFILE
fi
2  ext/dbase/config.m4
View
@@ -2,8 +2,6 @@ dnl
dnl $Id$
dnl
-AC_ARG_WITH(dbase,[],[enable_dbase=$withval])
-
PHP_ARG_ENABLE(dbase,whether to enable dbase support,
[ --enable-dbase Enable the bundled dbase library])
4 ext/dom/config.m4
View
@@ -3,11 +3,11 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(dom, whether to enable DOM support,
-[ --disable-dom Disable new DOM support.], yes)
+[ --disable-dom Disable new DOM support], yes)
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
- [ --with-libxml-dir[=DIR] DOM: libxml2 install prefix.], no, no)
+ [ --with-libxml-dir[=DIR] DOM: libxml2 install prefix], no, no)
fi
if test "$PHP_DOM" != "no"; then
2  ext/fbsql/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(fbsql, for FrontBase SQL92 (fbsql) support,
-[ --with-fbsql[=DIR] Include FrontBase support. DIR is the FrontBase base directory.])
+[ --with-fbsql[=DIR] Include FrontBase support. DIR is the FrontBase base directory])
if test "$PHP_FBSQL" != "no"; then
2  ext/fdf/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(fdftk, for FDF support,
-[ --with-fdftk[=DIR] Include FDF support.])
+[ --with-fdftk[=DIR] Include FDF support])
if test "$PHP_FDFTK" != "no"; then
2  ext/filepro/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(filepro,whether to enable the bundled filePro support,
-[ --enable-filepro Enable the bundled read-only filePro support.])
+[ --enable-filepro Enable the bundled read-only filePro support])
if test "$PHP_FILEPRO" = "yes"; then
AC_DEFINE(HAVE_FILEPRO, 1, [ ])
16 ext/gd/config.m4
View
@@ -8,40 +8,40 @@ dnl
PHP_ARG_WITH(gd, for GD support,
[ --with-gd[=DIR] Include GD support where DIR is GD install prefix.
- If DIR is not set, the bundled GD library will be used.])
+ If DIR is not set, the bundled GD library will be used])
if test -z "$PHP_JPEG_DIR"; then
PHP_ARG_WITH(jpeg-dir, for the location of libjpeg,
- [ --with-jpeg-dir[=DIR] GD: Set the path to libjpeg install prefix.], no, no)
+ [ --with-jpeg-dir[=DIR] GD: Set the path to libjpeg install prefix], no, no)
fi
if test -z "$PHP_PNG_DIR"; then
PHP_ARG_WITH(png-dir, for the location of libpng,
- [ --with-png-dir[=DIR] GD: Set the path to libpng install prefix.], no, no)
+ [ --with-png-dir[=DIR] GD: Set the path to libpng install prefix], no, no)
fi
if test -z "$PHP_ZLIB_DIR"; then
PHP_ARG_WITH(zlib-dir, for the location of libz,
- [ --with-zlib-dir[=DIR] GD: Set the path to libz install prefix.], no, no)
+ [ --with-zlib-dir[=DIR] GD: Set the path to libz install prefix], no, no)
fi
PHP_ARG_WITH(xpm-dir, for the location of libXpm,
-[ --with-xpm-dir[=DIR] GD: Set the path to libXpm install prefix.], no, no)
+[ --with-xpm-dir[=DIR] GD: Set the path to libXpm install prefix], no, no)
PHP_ARG_WITH(ttf, for FreeType 1.x support,
[ --with-ttf[=DIR] GD: Include FreeType 1.x support], no, no)
PHP_ARG_WITH(freetype-dir, for FreeType 2,
-[ --with-freetype-dir[=DIR] GD: Set the path to FreeType 2 install prefix.], no, no)
+[ --with-freetype-dir[=DIR] GD: Set the path to FreeType 2 install prefix], no, no)
PHP_ARG_WITH(t1lib, for T1lib support,
[ --with-t1lib[=DIR] GD: Include T1lib support. T1lib version >= 5.0.0 required], no, no)
PHP_ARG_ENABLE(gd-native-ttf, whether to enable truetype string function in GD,
-[ --enable-gd-native-ttf GD: Enable TrueType string function.], no, no)
+[ --enable-gd-native-ttf GD: Enable TrueType string function], no, no)
PHP_ARG_ENABLE(gd-jis-conv, whether to enable JIS-mapped Japanese font support in GD,
-[ --enable-gd-jis-conv GD: Enable JIS-mapped Japanese font support.], no, no)
+[ --enable-gd-jis-conv GD: Enable JIS-mapped Japanese font support], no, no)
dnl
dnl Checks for the configure options
2  ext/gettext/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(gettext,for GNU gettext support,
-[ --with-gettext[=DIR] Include GNU gettext support.])
+[ --with-gettext[=DIR] Include GNU gettext support])
if test "$PHP_GETTEXT" != "no"; then
for i in $PHP_GETTEXT /usr/local /usr; do
6 ext/imap/config.m4
View
@@ -86,13 +86,13 @@ AC_DEFUN([PHP_IMAP_SSL_CHK], [
PHP_ARG_WITH(imap,for IMAP support,
-[ --with-imap[=DIR] Include IMAP support. DIR is the c-client install prefix.])
+[ --with-imap[=DIR] Include IMAP support. DIR is the c-client install prefix])
PHP_ARG_WITH(kerberos,for IMAP Kerberos support,
-[ --with-kerberos[=DIR] IMAP: Include Kerberos support. DIR is the Kerberos install prefix.], no, no)
+[ --with-kerberos[=DIR] IMAP: Include Kerberos support. DIR is the Kerberos install prefix], no, no)
PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
-[ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix.], no, no)
+[ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
if test "$PHP_IMAP" != "no"; then
2  ext/informix/config.m4
View
@@ -4,7 +4,7 @@ dnl
PHP_ARG_WITH(informix,for Informix support,
[ --with-informix[=DIR] Include Informix support. DIR is the Informix base
- install directory, defaults to ${INFORMIXDIR:-nothing}.])
+ install directory, defaults to ${INFORMIXDIR:-nothing}])
if test "$PHP_INFORMIX" != "no"; then
4 ext/ldap/config.m4
View
@@ -63,10 +63,10 @@ AC_DEFUN([PHP_LDAP_SASL_CHECKS], [
])
PHP_ARG_WITH(ldap,for LDAP support,
-[ --with-ldap[=DIR] Include LDAP support.])
+[ --with-ldap[=DIR] Include LDAP support])
PHP_ARG_WITH(ldap-sasl,for LDAP Cyrus SASL support,
-[ --with-ldap-sasl[=DIR] LDAP: Include Cyrus SASL support.], no, no)
+[ --with-ldap-sasl[=DIR] LDAP: Include Cyrus SASL support], no, no)
if test "$PHP_LDAP" != "no"; then
4 ext/libxml/config0.m4
View
@@ -3,11 +3,11 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(libxml, whether to enable LIBXML support,
-[ --disable-libxml Disable new LIBXML support.], yes)
+[ --disable-libxml Disable new LIBXML support], yes)
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
- [ --with-libxml-dir[=DIR] libxml2 install prefix.], no, no)
+ [ --with-libxml-dir[=DIR] libxml2 install prefix], no, no)
fi
if test "$PHP_LIBXML" != "no"; then
2  ext/mcrypt/config.m4
View
@@ -21,7 +21,7 @@ AC_DEFUN([PHP_MCRYPT_CHECK_VERSION],[
PHP_ARG_WITH(mcrypt, for mcrypt support,
-[ --with-mcrypt[=DIR] Include mcrypt support.])
+[ --with-mcrypt[=DIR] Include mcrypt support])
if test "$PHP_MCRYPT" != "no"; then
for i in $PHP_MCRYPT /usr/local /usr; do
5 ext/mcve/config.m4
View
@@ -4,12 +4,9 @@ PHP_ARG_WITH(mcve, for MCVE support,
[ --with-mcve[=DIR] Include MCVE support. libmcve >= 3.2.2 or libmonetra >= 4.0 required])
PHP_ARG_WITH(openssl-dir,OpenSSL dir for MCVE,
-[ --with-openssl-dir[=DIR] MCVE: openssl install prefix.], no, no)
+[ --with-openssl-dir[=DIR] MCVE: openssl install prefix], no, no)
if test "$PHP_MCVE" != "no"; then
- dnl determine egrep command for AC_EGREP_CPP below
- AC_CHECK_PROG(EGREP, egrep, grep -E)
- AC_SUBST(EGREP)
if test "$PHP_OPENSSL_DIR" != "no"; then
PHP_OPENSSL=$PHP_OPENSSL_DIR
2  ext/mhash/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(mhash, for mhash support,
-[ --with-mhash[=DIR] Include mhash support.])
+[ --with-mhash[=DIR] Include mhash support])
if test "$PHP_MHASH" != "no"; then
for i in $PHP_MHASH /usr/local /usr /opt/mhash; do
2  ext/msql/config.m4
View
@@ -23,7 +23,7 @@ AC_DEFUN([PHP_MSQL_VERSION],[
PHP_ARG_WITH(msql,for mSQL support,
[ --with-msql[=DIR] Include mSQL support. DIR is the mSQL base
- install directory, defaults to /usr/local/Hughes.])
+ install directory, defaults to /usr/local/Hughes])
if test "$PHP_MSQL" != "no"; then
if test "$PHP_MSQL" = "yes"; then
2  ext/mssql/config.m4
View
@@ -4,7 +4,7 @@ dnl
PHP_ARG_WITH(mssql,for MSSQL support via FreeTDS,
[ --with-mssql[=DIR] Include MSSQL-DB support. DIR is the FreeTDS home
- directory, defaults to /usr/local/freetds.])
+ directory, defaults to /usr/local/freetds])
if test "$PHP_MSSQL" != "no"; then
10 ext/mysql/config.m4
View
@@ -40,15 +40,15 @@ AC_DEFUN([PHP_MYSQL_SOCKET_SEARCH], [
PHP_ARG_WITH(mysql, for MySQL support,
-[ --with-mysql[=DIR] Include MySQL support. DIR is the MySQL base directory.])
+[ --with-mysql[=DIR] Include MySQL support. DIR is the MySQL base directory])
PHP_ARG_WITH(mysql-sock, for specified location of the MySQL UNIX socket,
[ --with-mysql-sock[=DIR] MySQL: Location of the MySQL unix socket pointer.
- If unspecified, the default locations are searched.], no, no)
+ If unspecified, the default locations are searched], no, no)
if test -z "$PHP_ZLIB_DIR"; then
PHP_ARG_WITH(zlib-dir, for the location of libz,
- [ --with-zlib-dir[=DIR] MySQL: Set the path to libz install prefix.], no, no)
+ [ --with-zlib-dir[=DIR] MySQL: Set the path to libz install prefix], no, no)
fi
@@ -80,7 +80,7 @@ if test "$PHP_MYSQL" != "no"; then
if test -z "$MYSQL_DIR"; then
AC_MSG_ERROR([Cannot find MySQL header files under $PHP_MYSQL.
-Note that the MySQL client library is not bundled anymore.])
+Note that the MySQL client library is not bundled anymore!])
fi
for i in $PHP_LIBDIR $PHP_LIBDIR/mysql; do
@@ -89,7 +89,7 @@ Note that the MySQL client library is not bundled anymore.])
if test -z "$MYSQL_LIB_DIR"; then
AC_MSG_ERROR([Cannot find libmysqlclient under $MYSQL_DIR.
-Note that the MySQL client library is not bundled anymore.])
+Note that the MySQL client library is not bundled anymore!])
fi
PHP_CHECK_LIBRARY(mysqlclient, mysql_close, [ ],
4 ext/mysqli/config.m4
View
@@ -4,10 +4,10 @@ dnl config.m4 for extension mysqli
PHP_ARG_WITH(mysqli, for MySQLi support,
[ --with-mysqli[=FILE] Include MySQLi support. FILE is the optional pathname
- to mysql_config.])
+ to mysql_config])
PHP_ARG_ENABLE(embedded_mysqli, whether to enable embedded MySQLi support,
-[ --enable-embedded-mysqli MYSQLi: Enable embedded support.], no, no)
+[ --enable-embedded-mysqli MYSQLi: Enable embedded support], no, no)
if test "$PHP_MYSQLI" != "no"; then
2  ext/ncurses/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(ncurses, for ncurses support,
-[ --with-ncurses[=DIR] Include ncurses support (CLI/CGI only).])
+[ --with-ncurses[=DIR] Include ncurses support (CLI/CGI only)])
if test "$PHP_NCURSES" != "no"; then
2  ext/oci8/config.m4
View
@@ -87,7 +87,7 @@ if test "$PHP_OCI8" = "no"; then
Oracle Instant Client. DIR is the directory with the
Instant Client libraries. On Linux it will default to
/usr/lib/oracle/<most_recent_version>/client/lib
- Other platforms will need to have it explicitly specified.])
+ Other platforms will need to have it explicitly specified])
else
PHP_OCI8_INSTANT_CLIENT="no";
fi
24 ext/odbc/config.m4
View
@@ -93,7 +93,7 @@ if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for Adabas support)
AC_ARG_WITH(adabas,
[ --with-adabas[=DIR] Include Adabas D support. DIR is the Adabas base
- install directory, defaults to /usr/local.],
+ install directory [/usr/local]],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
@@ -125,7 +125,7 @@ if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for SAP DB support)
AC_ARG_WITH(sapdb,
[ --with-sapdb[=DIR] Include SAP DB support. DIR is SAP DB base
- install directory, defaults to /usr/local.],
+ install directory [/usr/local]],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
@@ -228,8 +228,8 @@ fi
if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for ODBCRouter.com support)
AC_ARG_WITH(ODBCRouter,
-[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support. DIR is ODBCRouter base
- install directory, defaults to /usr.],
+[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support. DIR is ODBCRouter base
+ install directory [/usr]],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
@@ -288,9 +288,8 @@ AC_MSG_CHECKING(for Empress local access support)
AC_ARG_WITH(empress-bcs,
[ --with-empress-bcs[=DIR]
Include Empress Local Access support. DIR is the
- Empress base install directory, defaults to
- \$EMPRESSPATH. From PHP 4, this option only supports
- Empress Version 8.60 and above.],
+ Empress base install directory. (Empress Version >= 8.60 required)
+ [\$EMPRESSPATH]],
[
PHP_WITH_SHARED
if test "$withval" != "no"; then
@@ -335,7 +334,7 @@ if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for Birdstep support)
AC_ARG_WITH(birdstep,
[ --with-birdstep[=DIR] Include Birdstep support. DIR is the Birdstep base
- install directory, defaults to /usr/local/birdstep.],
+ install directory [/usr/local/birdstep]],
[
PHP_WITH_SHARED
@@ -427,7 +426,7 @@ if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for iODBC support)
AC_ARG_WITH(iodbc,
[ --with-iodbc[=DIR] Include iODBC support. DIR is the iODBC base
- install directory, defaults to /usr/local.],
+ install directory [/usr/local]],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
@@ -455,8 +454,7 @@ if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
AC_ARG_WITH(esoob,
[ --with-esoob[=DIR] Include Easysoft OOB support. DIR is the OOB base
- install directory,
- defaults to /usr/local/easysoft/oob/client.],
+ install directory [/usr/local/easysoft/oob/client]],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
@@ -483,7 +481,7 @@ if test -z "$ODBC_TYPE"; then
AC_MSG_CHECKING(for unixODBC support)
AC_ARG_WITH(unixODBC,
[ --with-unixODBC[=DIR] Include unixODBC support. DIR is the unixODBC base
- install directory, defaults to /usr/local.],
+ install directory [/usr/local]],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
@@ -512,7 +510,7 @@ AC_ARG_WITH(dbmaker,
[ --with-dbmaker[=DIR] Include DBMaker support. DIR is the DBMaker base
install directory, defaults to where the latest
version of DBMaker is installed (such as
- /home/dbmaker/3.6).],
+ /home/dbmaker/3.6)],
[
PHP_WITH_SHARED
if test "$withval" = "yes"; then
2  ext/oracle/config.m4
View
@@ -26,7 +26,7 @@ AC_DEFUN([AC_ORACLE_VERSION],[
])
PHP_ARG_WITH(oracle, for Oracle-ORACLE support,
-[ --with-oracle[=DIR] Include Oracle-oci7 support. Default DIR is ORACLE_HOME.])
+[ --with-oracle[=DIR] Include Oracle-oci7 support. Default DIR is ORACLE_HOME])
if test "$PHP_ORACLE" != "no"; then
AC_MSG_CHECKING([Oracle Install-Dir])
2  ext/ovrimos/config.m4
View
@@ -4,7 +4,7 @@ dnl
PHP_ARG_WITH(ovrimos, for Ovrimos SQL Server support,
[ --with-ovrimos[=DIR] Include Ovrimos SQL Server support. DIR is the
- Ovrimos libsqlcli install directory.])
+ Ovrimos libsqlcli install directory])
if test "$PHP_OVRIMOS" != "no"; then
for i in $PHP_OVRIMOS /usr/local /usr; do
2  ext/pdo/config.m4
View
@@ -28,7 +28,7 @@ Once you've upgraded, please re-try your PDO install.
])
PHP_ARG_ENABLE(pdo, whether to enable PDO support,
-[ --enable-pdo=yes Enable PHP Data Objects support (recommended)], yes)
+[ --disable-pdo Disable PHP Data Objects support], yes)
if test "$PHP_PDO" != "no"; then
4 ext/pdo_firebird/config.m4
View
@@ -5,8 +5,8 @@ dnl
if test "$PHP_PDO" != "no"; then
PHP_ARG_WITH(pdo-firebird,for Firebird support for PDO,
-[ --with-pdo-firebird[=DIR] Include Firebird support for PDO. DIR is the Firebird base
- install directory, defaults to /opt/firebird])
+[ --with-pdo-firebird[=DIR] PDO: Firebird support. DIR is the Firebird base
+ install directory, defaults to /opt/firebird])
if test "$PHP_PDO_FIREBIRD" != "no"; then
if test "$PHP_PDO_FIREBIRD" = "yes"; then
4 ext/pdo_mysql/config.m4
View
@@ -15,7 +15,7 @@ AC_DEFUN([PDO_MYSQL_LIB_CHK], [
])
PHP_ARG_WITH(pdo-mysql, for MySQL support for PDO,
-[ --with-pdo-mysql[=DIR] Include MySQL support. DIR is the MySQL base directory.])
+[ --with-pdo-mysql[=DIR] PDO: MySQL support. DIR is the MySQL base directory])
if test "$PHP_PDO_MYSQL" != "no"; then
AC_DEFINE(HAVE_MYSQL, 1, [Whether you have MySQL])
@@ -40,7 +40,7 @@ if test "$PHP_PDO_MYSQL" != "no"; then
if test -z "$PDO_MYSQL_DIR"; then
AC_MSG_ERROR([Cannot find MySQL header files under $PHP_MYSQL.
-Note that the MySQL client library is not bundled anymore.])
+Note that the MySQL client library is not bundled anymore!])
fi
if test -x $PDO_MYSQL_CONFIG; then
10 ext/pdo_oci/config.m4
View
@@ -28,12 +28,10 @@ AC_DEFUN([AC_PDO_OCI_VERSION],[
])
PHP_ARG_WITH(pdo-oci, Oracle OCI support for PDO,
-[
- --with-pdo-oci[=DIR] Include Oracle-OCI support. Default DIR is ORACLE_HOME.
- You may also use --with-pdo-oci=instantclient,prefix,version to use
- the InstantClient SDK. For Linux with 10.1.0.3 rpms (for example) use:
- --with-pdo-oci=instantclient,/usr,10.1.0.3
-])
+[ --with-pdo-oci[=DIR] PDO: Oracle-OCI support. Default DIR is ORACLE_HOME.
+ You may also use --with-pdo-oci=instantclient,prefix,version to use
+ the InstantClient SDK. For Linux with 10.1.0.3 rpms (for example) use:
+ --with-pdo-oci=instantclient,/usr,10.1.0.3])
if test "$PHP_PDO_OCI" != "no"; then
AC_MSG_CHECKING([Oracle Install-Dir])
43 ext/pdo_odbc/config.m4
View
@@ -4,27 +4,22 @@ dnl vim:et:sw=2:ts=2:
if test "$PHP_PDO" != "no"; then
-AC_DEFUN([PDO_ODBC_HELP_TEXT], [[
- --with-pdo-odbc=flavour,dir Add support for "flavour" ODBC drivers,
- looking for include and lib dirs under "dir"
-
- flavour can be one of:
- ibm-db2, unixODBC, generic
-
- You may omit the ,dir part to use a reasonable default for
- the flavour you have selected. e.g.:
- --with-pdo-odbc=unixODBC
- will check for unixODBC under /usr/local
-
- You may attempt to use an otherwise unsupported driver using
- the generic flavour. The syntax for generic ODBC support is:
- --with-pdo-odbc=generic,dir,ldflags,cflags
-
- This extension will always be created as a shared extension
- named pdo_odbc.so
-]])
-
-PHP_ARG_WITH(pdo-odbc, ODBC v3 driver for PDO, PDO_ODBC_HELP_TEXT)
+define([PDO_ODBC_HELP_TEXT],[[
+ include and lib dirs are looked under 'dir'.
+ 'flavour' can be one of: ibm-db2, unixODBC, generic
+ If ',dir' part is omitted, default for the flavour
+ you have selected will used. e.g.:
+ --with-pdo-odbc=unixODBC
+ will check for unixODBC under /usr/local. You may attempt
+ to use an otherwise unsupported driver using the \"generic\"
+ flavour. The syntax for generic ODBC support is:
+ --with-pdo-odbc=generic,dir,ldflags,cflags
+ This extension will always be created as a shared extension
+ named pdo_odbc.so]])
+
+PHP_ARG_WITH(pdo-odbc, for ODBC v3 support for PDO,
+[ --with-pdo-odbc=flavour,dir
+ PDO: Support for 'flavour' ODBC driver.]PDO_ODBC_HELP_TEXT)
AC_DEFUN([PDO_ODBC_CHECK_HEADER],[
if test -f $PDO_ODBC_INCDIR/$1 ; then
@@ -33,7 +28,7 @@ AC_DEFUN([PDO_ODBC_CHECK_HEADER],[
])
if test "$PHP_PDO_ODBC" != "no"; then
- AC_MSG_CHECKING(which ODBC flavour you want)
+ AC_MSG_CHECKING([for selected PDO ODBC flavour])
pdo_odbc_flavour=`echo $withval | cut -d, -f1`
pdo_odbc_dir=`echo $withval | cut -d, -f2`
@@ -68,9 +63,7 @@ if test "$PHP_PDO_ODBC" != "no"; then
;;
*)
- AC_MSG_ERROR(Unknown ODBC flavour $pdo_odbc_flavour
-PDO_ODBC_HELP_TEXT
-)
+ AC_MSG_ERROR([Unknown ODBC flavour $pdo_odbc_flavour]PDO_ODBC_HELP_TEXT)
;;
esac
5 ext/pdo_pgsql/config.m4
View
@@ -8,9 +8,8 @@ AC_DEFUN([PHP_PGSQL_CHECK_FUNCTIONS],[
])
PHP_ARG_WITH(pdo-pgsql,for PostgreSQL support for PDO,
-[ --with-pdo-pgsql[=DIR] Include PDO PostgreSQL support. DIR
- is the PostgreSQL base install directory
- or the path to pg_config.])
+[ --with-pdo-pgsql[=DIR] PDO: PostgreSQL support. DIR is the PostgreSQL base
+ install directory or the path to pg_config])
if test "$PHP_PDO_PGSQL" != "no"; then
PHP_EXPAND_PATH($PGSQL_INCLUDE, PGSQL_INCLUDE)
2  ext/pdo_sqlite/config.m4
View
@@ -5,7 +5,7 @@ dnl vim:et:sw=2:ts=2:
if test "$PHP_PDO" != "no"; then
PHP_ARG_WITH(pdo-sqlite, for sqlite 3 driver for PDO,
-[ --with-pdo-sqlite Include PDO sqlite 3 support],yes)
+[ --without-pdo-sqlite PDO: sqlite 3 support],yes)
if test "$PHP_PDO_SQLITE" != "no"; then
2  ext/pfpro/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(pfpro, for Verisign Payflow Pro support,
-[ --with-pfpro[=DIR] Include Verisign Payflow Pro support.])
+[ --with-pfpro[=DIR] Include Verisign Payflow Pro support])
if test "$PHP_PFPRO" != "no"; then
PFPRO_LIB=libpfpro.so
2  ext/pgsql/config.m4
View
@@ -7,7 +7,7 @@ AC_DEFUN([PHP_PGSQL_CHECK_FUNCTIONS],[
PHP_ARG_WITH(pgsql,for PostgreSQL support,
[ --with-pgsql[=DIR] Include PostgreSQL support. DIR is the PostgreSQL
- base install directory or the path to pg_config.])
+ base install directory or the path to pg_config])
if test "$PHP_PGSQL" != "no"; then
PHP_EXPAND_PATH($PGSQL_INCLUDE, PGSQL_INCLUDE)
2  ext/pspell/config.m4
View
@@ -4,7 +4,7 @@ dnl
PHP_ARG_WITH(pspell,for PSPELL support,
[ --with-pspell[=DIR] Include PSPELL support.
- GNU Aspell version 0.50.0 or higher required.])
+ GNU Aspell version 0.50.0 or higher required])
if test "$PHP_PSPELL" != "no"; then
PHP_NEW_EXTENSION(pspell, pspell.c, $ext_shared)
4 ext/readline/config.m4
View
@@ -3,10 +3,10 @@ dnl $Id$
dnl
PHP_ARG_WITH(libedit,for libedit readline replacement,
-[ --with-libedit[=DIR] Include libedit readline replacement (CLI/CGI only).])
+[ --with-libedit[=DIR] Include libedit readline replacement (CLI/CGI only)])
PHP_ARG_WITH(readline,for readline support,
-[ --with-readline[=DIR] Include readline support (CLI/CGI only).])
+[ --with-readline[=DIR] Include readline support (CLI/CGI only)])
if test "$PHP_READLINE" != "no"; then
for i in $PHP_READLINE /usr/local /usr; do
2  ext/recode/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(recode,for recode support,
-[ --with-recode[=DIR] Include recode support.])
+[ --with-recode[=DIR] Include recode support])
if test "$PHP_RECODE" != "no"; then
RECODE_LIST="$PHP_RECODE /usr/local /usr /opt"
2  ext/session/config.m4
View
@@ -6,7 +6,7 @@ PHP_ARG_ENABLE(session, whether to enable PHP sessions,
[ --disable-session Disable session support], yes)
PHP_ARG_WITH(mm,for mm support,
-[ --with-mm[=DIR] Include mm support for session storage], no, no)
+[ --with-mm[=DIR] SESSION: Include mm support for session storage], no, no)
if test "$PHP_SESSION" != "no"; then
PHP_PWRITE_TEST
7 ext/snmp/config.m4
View
@@ -3,10 +3,10 @@ dnl $Id$
dnl
PHP_ARG_WITH(snmp,for SNMP support,
-[ --with-snmp[=DIR] Include SNMP support.])
+[ --with-snmp[=DIR] Include SNMP support])
PHP_ARG_WITH(openssl-dir,OpenSSL dir for SNMP,
-[ --with-openssl-dir[=DIR] SNMP: openssl install prefix.], no, no)
+[ --with-openssl-dir[=DIR] SNMP: openssl install prefix], no, no)
if test "$PHP_SNMP" != "no"; then
@@ -123,10 +123,9 @@ if test "$PHP_SNMP" != "no"; then
PHP_SUBST(SNMP_SHARED_LIBADD)
fi
-
AC_MSG_CHECKING(whether to enable UCD SNMP hack)
AC_ARG_ENABLE(ucd-snmp-hack,
-[ --enable-ucd-snmp-hack Enable UCD SNMP hack],[
+[ --enable-ucd-snmp-hack SNMP: Enable UCD SNMP hack],[
if test "$enableval" = "yes" ; then
AC_DEFINE(UCD_SNMP_HACK, 1, [ ])
AC_MSG_RESULT(yes)
2  ext/soap/config.m4
View
@@ -2,7 +2,7 @@ dnl $Id$
dnl config.m4 for extension soap
PHP_ARG_ENABLE(soap, whether to enable SOAP support,
-[ --enable-soap Include SOAP support.])
+[ --enable-soap Enable SOAP support])
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
4 ext/sqlite/config.m4
View
@@ -3,13 +3,13 @@ dnl config.m4 for extension sqlite
dnl vim:et:ts=2:sw=2
PHP_ARG_WITH(sqlite, for sqlite support,
-[ --without-sqlite Do not include sqlite support.
+[ --without-sqlite Do not include sqlite support.
Use --with-sqlite=DIR to specify DIR where
Sqlite include and library files are located,
if not using bundled library.], yes)
PHP_ARG_ENABLE(sqlite-utf8, whether to enable UTF-8 support in sqlite (default: ISO-8859-1),
-[ --enable-sqlite-utf8 Enable UTF-8 support for SQLite], no, no)
+[ --enable-sqlite-utf8 SQLite: Enable UTF-8 support for SQLite], no, no)
if test "$PHP_SQLITE" != "no"; then
if test "$PHP_PDO" != "no"; then
2  ext/standard/config.m4
View
@@ -216,7 +216,7 @@ AC_FLUSH_IO
divert(5)dnl
AC_ARG_WITH(regex,
-[ --with-regex=TYPE regex library type: system, apache, php. Default: php
+[ --with-regex=TYPE regex library type: system, apache, php. [TYPE=php]
WARNING: Do NOT use unless you know what you are doing!],
[
case $withval in
3  ext/sybase/config.m4
View
@@ -4,8 +4,7 @@ dnl
PHP_ARG_WITH(sybase,for Sybase support,
[ --with-sybase[=DIR] Include Sybase-DB support. DIR is the Sybase home
- directory, defaults to /home/sybase.])
-
+ directory, defaults to /home/sybase])
if test "$PHP_SYBASE" != "no"; then
if test "$PHP_SYBASE" = "yes"; then
2  ext/sybase_ct/config.m4
View
@@ -4,7 +4,7 @@ dnl
PHP_ARG_WITH(sybase-ct, for Sybase-CT support,
[ --with-sybase-ct[=DIR] Include Sybase-CT support. DIR is the Sybase home
- directory. Defaults to /home/sybase.])
+ directory. Defaults to /home/sybase])
if test "$PHP_SYBASE_CT" != "no"; then
2  ext/sysvsem/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(sysvsem,whether to enable System V semaphore support,
-[ --enable-sysvsem Enable System V semaphore support.])
+[ --enable-sysvsem Enable System V semaphore support])
if test "$PHP_SYSVSEM" != "no"; then
PHP_NEW_EXTENSION(sysvsem, sysvsem.c, $ext_shared)
2  ext/sysvshm/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(sysvshm,whether to enable System V shared memory support,
-[ --enable-sysvshm Enable the System V shared memory support.])
+[ --enable-sysvshm Enable the System V shared memory support])
if test "$PHP_SYSVSHM" != "no"; then
AC_DEFINE(HAVE_SYSVSHM, 1, [ ])
2  ext/tidy/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(tidy,for TIDY support,
-[ --with-tidy[=DIR] Include TIDY support])
+[ --with-tidy[=DIR] Include TIDY support])
if test "$PHP_TIDY" != "no"; then
2  ext/wddx/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
-[ --enable-wddx Enable WDDX support.])
+[ --enable-wddx Enable WDDX support])
if test "$PHP_WDDX" != "no"; then
if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
2  ext/xml/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_ENABLE(xml,whether to enable XML support,
-[ --disable-xml Disable XML support.], yes)
+[ --disable-xml Disable XML support], yes)
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
2  ext/xmlreader/config.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(xmlreader, for XMLReader support,
-[ --with-xmlreader Include XMLReader support.])
+[ --with-xmlreader Include XMLReader support])
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
6 ext/xmlrpc/config.m4
View
@@ -8,7 +8,7 @@ sinclude(libxmlrpc/acinclude.m4)
sinclude(libxmlrpc/xmlrpc.m4)
PHP_ARG_WITH(xmlrpc, for XMLRPC-EPI support,
-[ --with-xmlrpc[=DIR] Include XMLRPC-EPI support.])
+[ --with-xmlrpc[=DIR] Include XMLRPC-EPI support])
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
@@ -16,10 +16,10 @@ if test -z "$PHP_LIBXML_DIR"; then
fi
PHP_ARG_WITH(expat-dir, libexpat dir for XMLRPC-EPI,
-[ --with-expat-dir=DIR XMLRPC-EPI: libexpat dir for XMLRPC-EPI. (deprecated)],no,no)
+[ --with-expat-dir=DIR XMLRPC-EPI: libexpat dir for XMLRPC-EPI (deprecated)],no,no)
PHP_ARG_WITH(iconv-dir, iconv dir for XMLRPC-EPI,
-[ --with-iconv-dir=DIR XMLRPC-EPI: iconv dir for XMLRPC-EPI.],no,no)
+[ --with-iconv-dir=DIR XMLRPC-EPI: iconv dir for XMLRPC-EPI],no,no)
if test "$PHP_XMLRPC" != "no"; then
2  ext/xsl/config.m4
View
@@ -4,7 +4,7 @@ dnl
PHP_ARG_WITH(xsl, for XSL support,
[ --with-xsl[=DIR] Include new XSL support (requires libxslt >= 1.0.18).
- DIR is the libxslt install directory.])
+ DIR is the libxslt install directory])
if test "$PHP_XSL" != "no"; then
2  ext/zlib/config0.m4
View
@@ -3,7 +3,7 @@ dnl $Id$
dnl
PHP_ARG_WITH(zlib,for ZLIB support,
-[ --with-zlib[=DIR] Include ZLIB support (requires zlib >= 1.0.9).])
+[ --with-zlib[=DIR] Include ZLIB support (requires zlib >= 1.0.9)])
PHP_ARG_WITH(zlib-dir,if the location of ZLIB install directory is defined,
[ --with-zlib-dir=<DIR> Define the location of zlib install directory], no, no)
6 sapi/apache/config.m4
View
@@ -21,7 +21,7 @@ fi
AC_MSG_CHECKING(for Apache 1.x module support via DSO through APXS)
AC_ARG_WITH(apxs,
[ --with-apxs[=FILE] Build shared Apache 1.x module. FILE is the optional
- pathname to the Apache apxs tool; defaults to "apxs".],[
+ pathname to the Apache apxs tool [apxs]],[
if test "$withval" = "yes"; then
APXS=apxs
$APXS -q CFLAGS >/dev/null 2>&1
@@ -121,7 +121,7 @@ if test "$PHP_SAPI" != "apache"; then
AC_MSG_CHECKING(for Apache 1.x module support)
AC_ARG_WITH(apache,
[ --with-apache[=DIR] Build Apache 1.x module. DIR is the top-level Apache
- build directory, defaults to /usr/local/apache.],[
+ build directory [/usr/local/apache]],[
APACHE_INSTALL_FILES="\$(srcdir)/sapi/apache/mod_php5.* sapi/apache/libphp5.module"
@@ -238,7 +238,7 @@ fi
AC_MSG_CHECKING(for mod_charset compatibility option)
AC_ARG_WITH(mod_charset,
-[ --with-mod_charset Enable transfer tables for mod_charset (Rus Apache).],
+[ --with-mod_charset Enable transfer tables for mod_charset (Rus Apache)],
[
AC_MSG_RESULT(yes)
AC_DEFINE(USE_TRANSFER_TABLES,1,[ ])
4 sapi/apache2filter/config.m4
View
@@ -6,7 +6,7 @@ AC_MSG_CHECKING(for Apache 2.0 filter-module support via DSO through APXS)
AC_ARG_WITH(apxs2filter,
[ --with-apxs2filter[=FILE]
EXPERIMENTAL: Build shared Apache 2.0 Filter module. FILE is the optional
- pathname to the Apache apxs tool; defaults to "apxs".],[
+ pathname to the Apache apxs tool [apxs]],[
if test "$withval" = "yes"; then
APXS=apxs
$APXS -q CFLAGS >/dev/null 2>&1
@@ -62,7 +62,7 @@ AC_ARG_WITH(apxs2filter,
if test "$APACHE_VERSION" -le 2000000; then
AC_MSG_ERROR([You have enabled Apache 2 support while your server is Apache 1.3. Please use the appropiate switch --with-apxs (without the 2)])
elif test "$APACHE_VERSION" -lt 2000040; then
- AC_MSG_ERROR([Please note that Apache version >= 2.0.40 is required.])
+ AC_MSG_ERROR([Please note that Apache version >= 2.0.40 is required])
fi
APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
6 sapi/apache2handler/config.m4
View
@@ -4,8 +4,8 @@ dnl
AC_MSG_CHECKING(for Apache 2.0 handler-module support via DSO through APXS)
AC_ARG_WITH(apxs2,
-[ --with-apxs2[=FILE] EXPERIMENTAL: Build shared Apache 2.0 Handler module. FILE is the optional
- pathname to the Apache apxs tool; defaults to "apxs".],[
+[ --with-apxs2[=FILE] Build shared Apache 2.0 Handler module. FILE is the optional
+ pathname to the Apache apxs tool [apxs]],[
if test "$withval" = "yes"; then
APXS=apxs
$APXS -q CFLAGS >/dev/null 2>&1
@@ -61,7 +61,7 @@ AC_ARG_WITH(apxs2,
if test "$APACHE_VERSION" -le 2000000; then
AC_MSG_ERROR([You have enabled Apache 2 support while your server is Apache 1.3. Please use the appropiate switch --with-apxs (without the 2)])
elif test "$APACHE_VERSION" -lt 2000044; then
- AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required.])
+ AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required])
fi
APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
6 sapi/apache_hooks/config.m4
View
@@ -22,7 +22,7 @@ AC_MSG_CHECKING(for Apache 1.x (hooks) module support via DSO through APXS)
AC_ARG_WITH(apache-hooks,
[ --with-apache-hooks[=FILE]
EXPERIMENTAL: Build shared Apache 1.x module. FILE is the optional
- pathname to the Apache apxs tool; defaults to "apxs".],[
+ pathname to the Apache apxs tool [apxs]],[
if test "$withval" = "yes"; then
APXS=apxs
$APXS -q CFLAGS >/dev/null 2>&1
@@ -123,7 +123,7 @@ AC_MSG_CHECKING(for Apache 1.x (hooks) module support)
AC_ARG_WITH(apache-hooks-static,
[ --with-apache-hooks-static[=DIR]
EXPERIMENTAL: Build Apache 1.x module. DIR is the top-level Apache
- build directory, defaults to /usr/local/apache.],[
+ build directory [/usr/local/apache]],[
APACHE_INSTALL_FILES="\$(srcdir)/sapi/apache_hooks/mod_php5.* sapi/apache_hooks/libphp5.module"
@@ -240,7 +240,7 @@ fi
AC_MSG_CHECKING(for mod_charset compatibility option)
AC_ARG_WITH(mod_charset,
-[ --with-mod_charset Enable transfer tables for mod_charset (Rus Apache).],
+[ --with-mod_charset Enable transfer tables for mod_charset (Rus Apache)],
[
AC_MSG_RESULT(yes)
AC_DEFINE(USE_TRANSFER_TABLES,1,[ ])
5 sapi/caudium/config.m4
View
@@ -5,9 +5,8 @@ dnl
RESULT=no
AC_MSG_CHECKING(for Caudium support)
AC_ARG_WITH(caudium,
-[ --with-caudium[=DIR] Build PHP as a Pike module for use with Caudium
- DIR is the Caudium server dir, with the default value
- /usr/local/caudium/server.],
+[ --with-caudium[=DIR] Build PHP as a Pike module for use with Caudium.
+ DIR is the Caudium server dir [/usr/local/caudium/server]],
[
if test "$prefix" = "NONE"; then CPREF=/usr/local/; fi
if test ! -d $withval ; then
23 sapi/cgi/config9.m4
View
@@ -12,9 +12,9 @@ AC_ARG_ENABLE(cgi,
AC_ARG_ENABLE(force-cgi-redirect,
[ --enable-force-cgi-redirect
- Enable the security check for internal server
- redirects. You should use this if you are
- running the CGI version with Apache.],
+ CGI: Enable the security check for internal server
+ redirects. You should use this if you are
+ running the CGI version with Apache],
[
PHP_FORCE_CGI_REDIRECT=$enableval
],[
@@ -22,10 +22,10 @@ AC_ARG_ENABLE(force-cgi-redirect,
])
AC_ARG_ENABLE(discard-path,
-[ --enable-discard-path If this is enabled, the PHP CGI binary
- can safely be placed outside of the
- web tree and people will not be able
- to circumvent .htaccess security.],
+[ --enable-discard-path CGI: If this is enabled, the PHP CGI binary
+ can safely be placed outside of the
+ web tree and people will not be able
+ to circumvent .htaccess security],
[
PHP_DISCARD_PATH=$enableval
],[
@@ -33,8 +33,8 @@ AC_ARG_ENABLE(discard-path,
])
AC_ARG_ENABLE(fastcgi,
-[ --enable-fastcgi If this is enabled, the cgi module will
- be built with support for fastcgi also.],
+[ --enable-fastcgi CGI: If this is enabled, the cgi module will
+ be built with support for fastcgi also],
[
PHP_ENABLE_FASTCGI=$enableval
],[
@@ -42,9 +42,8 @@ AC_ARG_ENABLE(fastcgi,
])
AC_ARG_ENABLE(path-info-check,
-[ --disable-path-info-check
- If this is disabled, paths such as
- /info.php/test?a=b will fail to work.],
+[ --disable-path-info-check CGI: If this is disabled, paths such as
+ /info.php/test?a=b will fail to work],
[
PHP_ENABLE_PATHINFO_CHECK=$enableval
],[
2  sapi/cli/config.m4
View
@@ -6,7 +6,7 @@ AC_MSG_CHECKING(for CLI build)
AC_ARG_ENABLE(cli,
[ --disable-cli Disable building CLI version of PHP
- (this forces --without-pear).],
+ (this forces --without-pear)],
[
PHP_SAPI_CLI=$enableval
],[
3  sapi/continuity/config.m4
View
@@ -2,7 +2,8 @@ dnl ## $Id$ -*- sh -*-
AC_MSG_CHECKING(for Continuity support)
AC_ARG_WITH(continuity,
-[ --with-continuity=DIR Specify path to the installed Continuity Server],[
+[ --with-continuity=DIR Build PHP as Continuity Server module.
+ DIR is path to the installed Continuity Server root],[
PHP_CONTINUITY=$withval
],[
PHP_CONTINUITY=no
2  sapi/isapi/config.m4
View
@@ -5,7 +5,7 @@ dnl
RESULT=no
AC_MSG_CHECKING(for Zeus ISAPI support)
AC_ARG_WITH(isapi,
-[ --with-isapi[=DIR] Build PHP as an ISAPI module for use with Zeus.],
+[ --with-isapi[=DIR] Build PHP as an ISAPI module for use with Zeus],
[
if test "$withval" = "yes"; then
ZEUSPATH=/usr/local/zeus # the default
4 sapi/roxen/config.m4
View
@@ -6,7 +6,7 @@ RESULT=no
AC_MSG_CHECKING(for Roxen/Pike support)
AC_ARG_WITH(roxen,
[ --with-roxen=DIR Build PHP as a Pike module. DIR is the base Roxen
- directory, normally /usr/local/roxen/server.],
+ directory, normally /usr/local/roxen/server],
[
if test ! -d $withval ; then
AC_MSG_ERROR(You did not specify a directory)
@@ -44,7 +44,7 @@ if test "$RESULT" != "no" ; then
RESULT=no
AC_MSG_CHECKING(if Roxen should use ZTS)
AC_ARG_ENABLE(roxen-zts,
- [ --enable-roxen-zts Build the Roxen module using Zend Thread Safety.],
+ [ --enable-roxen-zts Build the Roxen module using Zend Thread Safety],
[
PHP_BUILD_THREAD_SAFE
AC_DEFINE(ROXEN_USE_ZTS,1,[Whether to use Roxen in ZTS mode])
Please sign in to comment.
Something went wrong with that request. Please try again.