Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Disable PEAR by default #3781

Closed
wants to merge 1 commit into
base: PHP-7.4
from

Conversation

7 participants
@nikic
Copy link
Member

nikic commented Feb 1, 2019

No description provided.

@KalleZ

This comment has been minimized.

Copy link
Member

KalleZ commented Feb 1, 2019

About time we go forward with this, +1

@KalleZ

KalleZ approved these changes Feb 1, 2019

@krakjoe krakjoe added the Quickfix label Feb 1, 2019

@@ -1136,8 +1136,7 @@ if test "$PHP_CLI" = "no"; then
fi

PHP_ARG_WITH(pear, [whether to install PEAR],
[ --with-pear=DIR Install PEAR in DIR @<:@PREFIX/lib/php@:>@
--without-pear Do not install PEAR], DEFAULT, yes)
[ --with-pear=DIR Install PEAR in DIR @<:@PREFIX/lib/php@:>@], no, yes)

This comment has been minimized.

@petk

petk Feb 1, 2019

Member

IMHO:

Suggested change
[ --with-pear=DIR Install PEAR in DIR @<:@PREFIX/lib/php@:>@], no, yes)
[ --with-pear=DIR Install PEAR in DIR @<:@PREFIX/lib/php@:>@ (deprecated)], no, yes)

...

@torinaki

This comment has been minimized.

Copy link

torinaki commented Feb 5, 2019

I have faced with the issue that PECL is part of PEAR and not sure there is a way to install it separately. Hope disabling PEAR is a short term solution

@nikic

This comment has been minimized.

Copy link
Member Author

nikic commented Feb 11, 2019

Merged as e93d6d9 together with a deprecation warning.

@torinaki No, this is not a short-term change. The option to install PEAR as part of the PHP installation process will be removed in the future. PEAR should be installed using go-pear.phar or similar instead. (Just like we don't install Composer as part of the PHP installation either.)

@nikic nikic closed this Feb 11, 2019

@khs1994 khs1994 referenced this pull request Feb 24, 2019

Open

PHP 7.4 #640

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.