Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tag: php-4.0b4

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

..
Octocat-spinner-32 Makefile.in
Octocat-spinner-32 README
Octocat-spinner-32 config.m4
Octocat-spinner-32 php.sym
Octocat-spinner-32 php_thttpd.h
Octocat-spinner-32 thttpd.c
Octocat-spinner-32 thttpd_patch
README
README FOR THTTPD MODULE (by Sascha Schumann)        ($Date$)

	This is a SAPI module for PHP 4.0 supporting thttpd, the tiny,
	turbo, throttling HTTP server by Jef Poskanzer.

	The module contains a patch against version 2.10 of thttpd. The patch
	adds hooks to thttpd to call PHP, if a filename matches *.php. This
	patch will be applied when you install PHP.

	While functional, this module exists primarily to demonstrate the ability
	of PHP to work in almost every web server environment.

REQUIRED DOWNLOADS

	1. thttpd 2.xx
	   
	   Full Distribution:
	   http://www.acme.com/software/thttpd/
	   
	2. PHP 4.0.x
	   
	   Beta Versions:
	   http://www.php.net/version4/
	   
	   Snapshots:
	   http://va.php.net/~sas/snapshots/


BUILD INSTRUCTIONS

	1. Extract software packages

	   $ gunzip -c thttpd-2.xx.tar.gz | tar xf -
	   $ gunzip -c php-*.tar.gz | tar xf -

	2. Prepare PHP

	   $ cd php-*
	   $ ./configure \
	   		--with-thttpd=../thttpd-2.xx \
			<further PHP options>
	   $ make install
	   $ cd ..
	
	   You can see the list of valid PHP options by executing

	   $ ./configure --help

	3. Configure, compile, install thttpd

	   Now follow the thttpd instructions. The Makefile template of
	   thttpd was changed to automatically use the components
	   required by PHP. 
Something went wrong with that request. Please try again.