Dependencies with @dev stability #1120

Closed
flip111 opened this Issue Feb 17, 2014 · 9 comments

Projects

None yet

4 participants

@flip111

Is it possible to use the latest stable of dompdf https://github.com/dompdf/dompdf/releases and Document https://github.com/zetacomponents/Document/releases ?? this to avoid having to specify a "dev-master@dev" version in a project which a minimum stability of stable.

@mvriel
phpDocumentor member

I am waiting for @dompdf to make a release as we need the latest features it has to offer. ZetaComponents can be changed to the latest stable now that they have ran a tag. There used to be a bug that hindered the project

@mvriel mvriel added this to the 2.4 milestone Feb 17, 2014
@mvriel mvriel added the Improvement label Feb 17, 2014
@flip111

dompdf is from 11 days ago at the moment ... needing even newer features ??

@mvriel
phpDocumentor member

Errhmm.. no. I just missed that they tagged :)

@ste93cry

You relased a new version a few days ago but the dependencies are still marked as dev. Can you fix them?

@betawax

Any news on this? Composer install fails with minimum-stability set to stable.

@mvriel
phpDocumentor member

I will fix it today or tomorrow and tag a new build release so that the composer installs work again

@mvriel
phpDocumentor member

I have used the latest tags for DOMPDF and ezcDocument and tagged version 2.3.2. You should be able to use the stable version now.

@mvriel mvriel added the Waiting label Mar 7, 2014
@betawax

Awesome, thank you!

@mvriel mvriel closed this in 178a2e6 Mar 9, 2014
@flip111

👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment