Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Problem with the PHP XSL extension #777

Closed
GuigZ- opened this Issue Mar 15, 2013 · 2 comments

Comments

Projects
None yet
2 participants

GuigZ- commented Mar 15, 2013

Hi,

When i generate the doc, i've a problem with the XSL extension :

The XSL writer was unable to find your XSLTProcessor; please check if you have installed the PHP XSL extension

phpDoc version : 2.0.0a12
php with wamp : 5.4.3

I think that a problem come with wamp but it's just a possibility.

thanks

Contributor

boenrobot commented Mar 15, 2013

Well, as the message says... Do you have the XSL extension enabled?

If you aren't sure...

On the command line, run

php -r phpinfo(INFO_MODULES);

and see if near the end, you can see something akin to

xsl

XSL => enabled
libxslt Version => 1.1.23
libxslt compiled against libxml Version => 2.6.32
EXSLT => enabled
libexslt Version => 0.8.13

(the exact numbers may differ, but the key is to have "XSL => enabled")

GuigZ- commented Mar 15, 2013

Oh okay,

In my wamp, this extensien was enabled, but not in my php.

Thanks for your help

@GuigZ- GuigZ- closed this Mar 15, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment