New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Issue warning for $pageroot only when not command line. #449

Merged
merged 1 commit into from Dec 3, 2018

Conversation

Projects
None yet
4 participants
@bramley
Copy link
Contributor

bramley commented Dec 3, 2018

The earlier pull request #443 doesn't work properly when phplist is run from the command line. The warning is always issued because REQUEST_URI does not exist.

This change is to test $pageroot only when phplist is not run from the command line.

@@ -684,7 +684,7 @@ function mb_strtolower($string)
Warn($GLOBALS['I18N']->get('You are trying to use PDF support without having FPDF loaded'));
}
if (WARN_ABOUT_PHP_SETTINGS) {
if (WARN_ABOUT_PHP_SETTINGS && !$commandline) {

This comment has been minimized.

@xh3n1

xh3n1 Dec 3, 2018

Member

@bramley maybe use !$GLOBALS['commandline'] instead?

@bramley bramley force-pushed the bramley:pageroot_warning branch from 721bbe9 to ee0a18a Dec 3, 2018

@bramley

This comment has been minimized.

Copy link
Contributor

bramley commented Dec 3, 2018

That would be more consistent with the rest of the file.

@xh3n1

xh3n1 approved these changes Dec 3, 2018

@samtuke samtuke merged commit 501c8d3 into phpList:master Dec 3, 2018

@bramley bramley deleted the bramley:pageroot_warning branch Dec 18, 2018

@splaquet

This comment has been minimized.

Copy link

splaquet commented Jan 20, 2019

I just ran into this error again. I was installing a fresh install into a sub-domain.

i set this:
$pageroot = '/';

and this, hoping it might help:
define('HTTP_HOST','lists.#####.com');

i haven't found a way to have the error message go away before install... but then, after install... i noticed that it contained ".com//?" on the settings page. error went away after I removed the / in pageroot.

updated to:
$pageroot = '';

also, this line should probably be cleaned up. looks like what should be 2 lines bumped together, onto 1 line:
**The pageroot in your config does not match the current locationCheck your config file.**`

screenshot 2019-01-20 16 34 04

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment