New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[ticket/15926] Deny 3.2.x installation if PHP >= 7.3-dev #5498

Merged
merged 5 commits into from Jan 6, 2019

Conversation

Projects
None yet
5 participants
@3D-I
Copy link
Contributor

3D-I commented Jan 5, 2019

PHPBB3-15926

Checklist:

  • Correct branch: master for new features; 3.2.x for fixes
  • Tests pass
  • Code follows coding guidelines: master and 3.2.x
  • Commit follows commit message format

Tracker ticket (set the ticket ID to your ticket ID):

https://tracker.phpbb.com/browse/PHPBB3-15926

3D-I added some commits Dec 24, 2018

@@ -20,9 +20,9 @@
$phpbb_root_path = '../';
$phpEx = substr(strrchr(__FILE__, '.'), 1);
if (version_compare(PHP_VERSION, '5.4') < 0)
if ( version_compare(PHP_VERSION, '5.4.7', '<') || version_compare(PHP_VERSION, '7.3-dev', '>=') )

This comment has been minimized.

@marc1706

marc1706 Jan 5, 2019

Member

Should be this according to coding guidelines:

Suggested change Beta
if ( version_compare(PHP_VERSION, '5.4.7', '<') || version_compare(PHP_VERSION, '7.3-dev', '>=') )
if (version_compare(PHP_VERSION, '5.4.7', '<') || version_compare(PHP_VERSION, '7.3-dev', '>='))

This comment has been minimized.

@3D-I

3D-I Jan 5, 2019

Contributor

Ok, though I think that the code's readability gains here.

3D-I added some commits Jan 5, 2019

{
die('You are running an unsupported PHP version. Please upgrade to PHP 5.4.0 or higher before trying to install or update to phpBB 3.2');
die('You are running an unsupported PHP version. Please upgrade to PHP equal or greater than 5.4.7 but less than 7.3-dev in order to install or update to phpBB 3.2');

This comment has been minimized.

@VSEphpbb

VSEphpbb Jan 5, 2019

Member

should be more like:
equal to or greater than 5.4.7

@3D-I 3D-I closed this Jan 6, 2019

@3D-I 3D-I reopened this Jan 6, 2019

marc1706 added a commit to marc1706/phpbb that referenced this pull request Jan 6, 2019

Merge pull request phpbb#5498 from 3D-I/ticket/15926
[ticket/15926] Deny 3.2.x installation if PHP >= 7.3-dev

@marc1706 marc1706 added this to the 3.2.6 milestone Jan 6, 2019

@marc1706 marc1706 merged commit a0efae7 into phpbb:3.2.x Jan 6, 2019

2 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@marc1706 marc1706 added the 3.2 (Rhea) label Jan 6, 2019

@3D-I 3D-I deleted the 3D-I:ticket/15926 branch Jan 6, 2019

@Solidjeuh

This comment has been minimized.

Copy link

Solidjeuh commented Jan 7, 2019

Why hardcoded language? Should be added in the language files...

@DavidIQ

This comment has been minimized.

Copy link
Member

DavidIQ commented Jan 7, 2019

Because loading the language would mean loading phpBB, which is what this change attempts to do for PHP 7.3+

@VSEphpbb

This comment has been minimized.

Copy link
Member

VSEphpbb commented Jan 7, 2019

Because it has to be installed to load the language sustem, but this error comes before it is installed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment