Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

I cannot find readline.h #889

Open
oNdsen opened this issue Jul 12, 2017 · 4 comments

Comments

@oNdsen
Copy link

commented Jul 12, 2017

Output

checking for libedit readline replacement... yes
configure: error: Please reinstall libedit - I cannot find readline.h

Expected Result

compiled php version

Command

$ phpbrew --debug install 7.0 +everything

Build Log

https://gist.github.com/oNdsen/f6231c0aef5a7492427a0689219fd518

Platform

OS:
Debian GNU/Linux 8 (jessie)

Running PHP:
doesnt matter. tried with 5.6, 7.0, 7.1

Installing PHP:
tryed each one of the following versions:
7.1.7, 7.0.21, 7.0.20, 5.6.31

Comment

this problem exists on 3 different debian servers. each server has allready compiled php versions installed (on january, via same phpbrew installation).
what ive done:

$ phpbrew update
$ phpbrew --debug install 7.0 +everything

so, readline is installed. i just cannot compile a new php version after i updated phpbrew (doesnt matter with or without extensions).

root@web01:~# apt-get install libedit2 libreadline6 libreadline6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libedit2 is already the newest version.
libreadline6 is already the newest version.
libreadline6-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
root@web01:~# find / -name "readline.h"
/usr/include/readline/readline.h

@mzalazar

This comment has been minimized.

Copy link

commented Jul 19, 2017

Try:
apt-get install libedit-dev

@ZeeCoder

This comment has been minimized.

Copy link

commented Oct 20, 2017

This fixed it for me: https://stackoverflow.com/questions/23085076/readline-readline-h-file-not-found#23085474

Run sudo apt-get install libreadline-dev

@arifikhsan

This comment has been minimized.

Copy link

commented Jan 31, 2019

so many errors

@mclucario

This comment has been minimized.

Copy link

commented Mar 5, 2019

Under Fedora 29 you need "readline-devel" to build. Maybe we should add that to the requirements since the default phpbrew install 7.0 includes that extension.

Edit: I ran into this issue today

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.