New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test against lowest possible dependencies #416

Merged
merged 1 commit into from Dec 1, 2016

Conversation

Projects
None yet
2 participants
@jyggen

jyggen commented Dec 1, 2016

The current minimum required version ^2.0.4 of pdepend/pdepend is a lie and the tests don't pass with this version installed. I bumped it to the lowest I could get all tests to pass with and took the liberty to make sure Travis runs the tests against the lowest possible versions as well as against what's in the lock file.

@ravage84 ravage84 added the Enhancement label Dec 1, 2016

@ravage84 ravage84 added this to the 2.5.1 milestone Dec 1, 2016

@ravage84 ravage84 merged commit 866129c into phpmd:master Dec 1, 2016

1 of 2 checks passed

continuous-integration/appveyor/pr AppVeyor build failed
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@ravage84

This comment has been minimized.

Member

ravage84 commented Dec 1, 2016

Many thanks 🙇

@jyggen

This comment has been minimized.

jyggen commented Dec 1, 2016

Thanks! :)

@ravage84 ravage84 modified the milestones: 2.5.1, 2.6.0 Jan 30, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment