Permalink
Browse files

patch #2478940 [core] PHP 5.2+ warning does not work

  • Loading branch information...
lem9 committed Jan 1, 2009
1 parent 3b4ffa2 commit 524e217667184036f758ecfdbd1c5ce4a405385b
Showing with 10 additions and 6 deletions.
  1. +2 −0 ChangeLog
  2. +8 −6 libraries/common.inc.php
View
@@ -23,6 +23,8 @@ $HeadURL: https://phpmyadmin.svn.sourceforge.net/svnroot/phpmyadmin/trunk/phpMyA
- bug #2445213 [export] Commas for CSV Excel 2008 for Mac
- bug #2397877 [core] ForceSSL and http auth_type
- bug #2473127 [display] Deleting rows displays tbl structure, not contents
- patch #2478940 [core] PHP 5.2+ warning does not work,
thanks to Jürgen Wind - windkiel
3.1.1.0 (2008-12-09)
- patch #2242765 [core] Navi panel server links wrong,
View
@@ -31,6 +31,14 @@
* @version $Id$
*/
/**
* Minimum PHP version; can't call PMA_fatalError() which uses a
* PHP 5 function, so cannot easily localize this message.
*/
if (version_compare(PHP_VERSION, '5.2.0', 'lt')) {
die('PHP 5.2+ is required');
}
/**
* the error handler
*/
@@ -72,13 +80,7 @@
/**
* the PMA_Theme class
* (this one is the first to produce a fatal error under PHP < 5)
* and let's put here the same minimum requirement as in our doc.
*/
if (version_compare(PHP_VERSION, '5.2.0') < 0 ) {
PMA_fatalError('strUpgrade', array('PHP', '5.2'));
}
require_once './libraries/Theme.class.php';
/**

0 comments on commit 524e217

Please sign in to comment.