New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Database with dot (.) in name is not shown when DisableIS is set to true and non root user #13267

Closed
NatsumeYuujinchou opened this Issue May 11, 2017 · 7 comments

Comments

Projects
None yet
5 participants
@NatsumeYuujinchou

NatsumeYuujinchou commented May 11, 2017

Steps to reproduce

  1. create a database with dot in name for example exa.db
  2. add $cfg['Servers'][$i]['DisableIS'] = true; to config.inc.php
  3. login to phpmyadmin, the database exa.db is not listed

Server configuration

Operating system
CentOS 7

Web server:
tested with Apache and LiteSpeed

Database:
MySQL 5.6

PHP version:
PHP 5.6

phpMyAdmin version:
tested with 4.6.6 and 4.7.0, both have the issue

@nijel nijel added the bug label May 15, 2017

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jun 6, 2017

Member

I can't reproduce this, it also works on the demo server. Don't you have set $cfg['Servers'][$i]['hide_db'] or $cfg['Servers'][$i]['only_db']?

Member

nijel commented Jun 6, 2017

I can't reproduce this, it also works on the demo server. Don't you have set $cfg['Servers'][$i]['hide_db'] or $cfg['Servers'][$i]['only_db']?

@NatsumeYuujinchou

This comment has been minimized.

Show comment
Hide comment
@NatsumeYuujinchou

NatsumeYuujinchou Jun 6, 2017

Neither of them are set.

NatsumeYuujinchou commented Jun 6, 2017

Neither of them are set.

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jun 7, 2017

Member

Any other changed settings? Can you post your config.inc.php (remove any passwords you happen to have there)?

Member

nijel commented Jun 7, 2017

Any other changed settings? Can you post your config.inc.php (remove any passwords you happen to have there)?

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jul 17, 2017

Member

Also can you please try if it's listed when executing SHOW DATABASES query?

Member

nijel commented Jul 17, 2017

Also can you please try if it's listed when executing SHOW DATABASES query?

@nijel nijel self-assigned this Jul 17, 2017

@nijel nijel closed this Aug 29, 2017

@nijel nijel added question and removed bug labels Feb 27, 2018

@kgrand84

This comment has been minimized.

Show comment
Hide comment
@kgrand84

kgrand84 Feb 27, 2018

This issue is happening for non privileged users.

  • phpMyAdmin v4.7.7
  • PHP version: 5.6.30
  • MySQL 5.5
  • OS: Centos 7.4
  • Using cPanel v70.

Set DisableIS=true
As a user with non-root privileges, create two databases: db1 and db.2
Go into phpMyAdmin as the non-root user, and see that db1 is there but db.2 is not.
Go into phpMyAdmin as root, and see both db1 and db.2 are visible.

kgrand84 commented Feb 27, 2018

This issue is happening for non privileged users.

  • phpMyAdmin v4.7.7
  • PHP version: 5.6.30
  • MySQL 5.5
  • OS: Centos 7.4
  • Using cPanel v70.

Set DisableIS=true
As a user with non-root privileges, create two databases: db1 and db.2
Go into phpMyAdmin as the non-root user, and see that db1 is there but db.2 is not.
Go into phpMyAdmin as root, and see both db1 and db.2 are visible.

@nijel nijel added bug and removed question labels Mar 1, 2018

@nijel nijel reopened this Mar 1, 2018

@nijel nijel removed their assignment Mar 1, 2018

@nijel nijel changed the title from Database with dot (.) in name is not shown when DisableIS is set to true to Database with dot (.) in name is not shown when DisableIS is set to true and non root user Mar 1, 2018

@williamdes

This comment has been minimized.

Show comment
Hide comment
@williamdes

williamdes Jun 10, 2018

Member

I can not reproduce this issue, the databases shows in CLI with SHOW DATABASES;.
Using MariaDB 10.2.15 + phpMyAdmin 4.7.7 or 4.8.1.

@kgrand84

can you please try if it's listed when executing SHOW DATABASES query?

Member

williamdes commented Jun 10, 2018

I can not reproduce this issue, the databases shows in CLI with SHOW DATABASES;.
Using MariaDB 10.2.15 + phpMyAdmin 4.7.7 or 4.8.1.

@kgrand84

can you please try if it's listed when executing SHOW DATABASES query?

@kgrand84

This comment has been minimized.

Show comment
Hide comment
@kgrand84

kgrand84 Jun 11, 2018

kgrand84 commented Jun 11, 2018

ryeddula added a commit to ryeddula/phpmyadmin that referenced this issue Jul 5, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>

ryeddula added a commit to ryeddula/phpmyadmin that referenced this issue Jul 5, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>

ryeddula added a commit to ryeddula/phpmyadmin that referenced this issue Jul 5, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>

ryeddula added a commit to ryeddula/phpmyadmin that referenced this issue Jul 5, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>

ryeddula added a commit to ryeddula/phpmyadmin that referenced this issue Jul 5, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>

mauriciofauth added a commit that referenced this issue Sep 12, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>

@mauriciofauth mauriciofauth self-assigned this Sep 12, 2018

mauriciofauth added a commit that referenced this issue Sep 12, 2018

Ensure that database names with '.' are handled properly when Disable…
…IS is true

Closes: #13267

Signed-off-by: Rishwanth Yeddula <rish@cpanel.net>
(cherry picked from commit 1aed791)
Signed-off-by: Maurício Meneghini Fauth <mauriciofauth@gmail.com>

mauriciofauth added a commit that referenced this issue Sep 12, 2018

Add ChangeLog entry for #13267
Signed-off-by: Maurício Meneghini Fauth <mauriciofauth@gmail.com>

@mauriciofauth mauriciofauth added this to the 4.8.4 milestone Sep 12, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment