New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Phpmyadmin "Show binary contents as HEX" missing #13336

Closed
SHUFIL opened this Issue May 31, 2017 · 9 comments

Comments

Projects
None yet
2 participants
@SHUFIL

SHUFIL commented May 31, 2017

Steps to reproduce

  1. i have installed mysqli
  2. i have tryd to add $cfg['DisplayBinaryAsHex'] = false; in config file
  3. and $cfg['ProtectBinary'] = FALSE;
    $cfg['DisplayBinaryAsHex'] = FALSE;
    $cfg['ShowBlob'] = TRUE;

Expected behaviour

I have installed phpmyadmin , issue is date and time is showing as a BLOB , also i noticed that
Show binary contents as HEX is missing
phpmyadmin vertion 5

Actual behaviour

Tell us what happens instead

Server configuration

centos 6.8:

apache 2.4:

Mysql 5.6:

PHP version 5.6:

phpMyAdmin version 5:

Client configuration

chrome:

Centos 6.8:

@SHUFIL

This comment has been minimized.

Show comment
Hide comment
@SHUFIL

SHUFIL Jun 5, 2017

could you please help any one , for my issue

SHUFIL commented Jun 5, 2017

could you please help any one , for my issue

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jul 17, 2017

Member

What phpMyAdmin version are you using? We don't have version 5 (latest phpMyAdmin is 4.7.2).

Member

nijel commented Jul 17, 2017

What phpMyAdmin version are you using? We don't have version 5 (latest phpMyAdmin is 4.7.2).

@nijel nijel added the question label Jul 17, 2017

@nijel nijel self-assigned this Jul 17, 2017

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jul 17, 2017

Member

Aslo showing screenshot of the problem might he useful, even better with SQL dump with the structure of the problematic table.

Member

nijel commented Jul 17, 2017

Aslo showing screenshot of the problem might he useful, even better with SQL dump with the structure of the problematic table.

@SHUFIL

This comment has been minimized.

Show comment
Hide comment
@SHUFIL

SHUFIL Jul 18, 2017

SHUFIL commented Jul 18, 2017

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jul 18, 2017

Member

Sorry, GitHub doesn't support adding attachments from mail, can you please upload it on the web?

Member

nijel commented Jul 18, 2017

Sorry, GitHub doesn't support adding attachments from mail, can you please upload it on the web?

@SHUFIL

This comment has been minimized.

Show comment
Hide comment
@SHUFIL

SHUFIL Jul 18, 2017

phpmyadmin
if i run SELECT NOW() in phpmyadmin, result seems as BLOB format , plz check attachment

SHUFIL commented Jul 18, 2017

phpmyadmin
if i run SELECT NOW() in phpmyadmin, result seems as BLOB format , plz check attachment

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jul 18, 2017

Member

It seems something is wrong in your MySQL setup - maybe mixed MySQL libraries.

Can you try executing following PHP code to diagnose that (you will have to fill in your database credentials):

<?php
$link = mysqli_connect('localhost', 'user', 'password');
$result = mysqli_query($link, 'SELECT NOW()');
$flags = mysqli_fetch_field_direct($result, 0);
var_dump($flags);
Member

nijel commented Jul 18, 2017

It seems something is wrong in your MySQL setup - maybe mixed MySQL libraries.

Can you try executing following PHP code to diagnose that (you will have to fill in your database credentials):

<?php
$link = mysqli_connect('localhost', 'user', 'password');
$result = mysqli_query($link, 'SELECT NOW()');
$flags = mysqli_fetch_field_direct($result, 0);
var_dump($flags);
@SHUFIL

This comment has been minimized.

Show comment
Hide comment
@SHUFIL

SHUFIL Jul 18, 2017

SHUFIL commented Jul 18, 2017

@nijel

This comment has been minimized.

Show comment
Hide comment
@nijel

nijel Jul 18, 2017

Member

Okay, installing mysqli extension might be good start, you're apparently using older mysql one and that might be cause of problems.

Member

nijel commented Jul 18, 2017

Okay, installing mysqli extension might be good start, you're apparently using older mysql one and that might be cause of problems.

@nijel nijel closed this Aug 29, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment