New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Two-factor: better reporting for missing dependencies #13827

Closed
ibennetch opened this Issue Nov 22, 2017 · 0 comments

Comments

Projects
None yet
2 participants
@ibennetch
Member

ibennetch commented Nov 22, 2017

Instead of the message "Two-factor authentication is not available, please install optional dependencies to enable authentication backends.", I think we should detect which dependencies are missing and present the error message more like:

Two-factor authentication is not available, please install optional dependencies to enable authentication backends. Missing Composer dependencies:

  • pragmarx/google2fa
  • bacon/bacon-qr-code
  • samyoul/u2f-php-server (for FIDO U2F authentication)

(or optionally drop "Composer" from the second sentence).

@nijel nijel added the enhancement label Nov 23, 2017

@nijel nijel self-assigned this Nov 27, 2017

@nijel nijel added this to the 4.8.0 milestone Nov 27, 2017

@nijel nijel closed this in 223e4f7 Nov 27, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment