New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

error 404 on creating new view in new PhpMyAdmin releases #14082

Open
DoctorSubtilis opened this Issue Mar 14, 2018 · 10 comments

Comments

Projects
None yet
6 participants
@DoctorSubtilis

DoctorSubtilis commented Mar 14, 2018

Steps to reproduce

  1. search in a table for a field value (e.g. "Raffaello" in "artist")
    2.get a query (ok)
    3.in "Query results operations" try to "create view"

Expected behaviour

A mask to set parametres of view

Actual behaviour

Error message 404:
"Error in processing request
Error code: 404
Error text: Not Found (rejected)
It seems that the connection to server has been lost.
Please check your network connectivity and server status"

Server configuration

Operating system: Kubuntu 17.10

Web server: localhost Apache/2.4.29 (Unix)
Database: MariaDB (Server version: 10.1.30-MariaDB)
PHP version: 7.2.1
phpMyAdmin version: 4.7.9

Client configuration

Browser: Qupzilla

Operating system: Kubuntu 17.10

Note that with PMA 4.7.4 it's all ok.
From access.log: "::1 - - [16/Mar/2018:08:01:30 +0100] "GET /web/web-pro/phpMyAdmin.new/view_create.php&ajax_request=1&ajax_dialog=1 HTTP/1.1" 404 1030"

@DoctorSubtilis DoctorSubtilis changed the title from error 404 on creating new view in new PMA releases to error 404 on creating new view in new PhpMyAdmin releases Mar 15, 2018

nulll-pointer added a commit to nulll-pointer/phpmyadmin that referenced this issue Mar 17, 2018

Fixes error 404 on creating views, issue phpmyadmin#14082
Signed-off-by: Lakshay arora <arora.lakshya123@gmail.com>
@DoctorSubtilis

This comment has been minimized.

DoctorSubtilis commented Mar 19, 2018

Fixed by null-pointer here: thank you!

nulll-pointer added a commit to nulll-pointer/phpmyadmin that referenced this issue Mar 29, 2018

Fixes error 404 on creating views, issue phpmyadmin#14082
Signed-Off-By: Lakshya arora <arora.lakshya123@gmail.com>

nulll-pointer added a commit to nulll-pointer/phpmyadmin that referenced this issue Mar 29, 2018

Fixes error 404 on creating views, issue phpmyadmin#14082
Signed-off-by: Lakshay arora <arora.lakshya123@gmail.com>

@mauriciofauth mauriciofauth self-assigned this Mar 29, 2018

@mauriciofauth mauriciofauth added the bug label Mar 29, 2018

@mauriciofauth mauriciofauth added this to the 4.8.0 milestone Mar 29, 2018

mauriciofauth added a commit that referenced this issue Mar 29, 2018

Fixes error 404 on creating views, issue #14082
Signed-off-by: Lakshay arora <arora.lakshya123@gmail.com>

(cherry picked from commit 29c4538)
Signed-off-by: Maurício Meneghini Fauth <mauriciofauth@gmail.com>
@DoctorSubtilis

This comment has been minimized.

DoctorSubtilis commented Apr 4, 2018

Not fully solved: now the dialog popup appears, as expected, but I I try to save the view I get an error message: "#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 3".
Edit inline: CREATE VIEW studi__Agazzi AS

Note that the new rc1 of PMA present still the problem you have fixed

With a old release of PMA I can create a view, with this code SELECT * FROM bibliografieWHEREautoreLIKE 'Agazzi' ORDER BYIDASC

@DoctorSubtilis

This comment has been minimized.

DoctorSubtilis commented Apr 4, 2018

The solution proposed here by mauriciofauth does not work for me (always empty the field "as").

@mauriciofauth

This comment has been minimized.

Member

mauriciofauth commented Apr 8, 2018

@DoctorSubtilis Thanks for pointing this out.

@mauriciofauth mauriciofauth reopened this Apr 8, 2018

@DoctorSubtilis

This comment has been minimized.

DoctorSubtilis commented Apr 8, 2018

You're welcome!

@DoctorSubtilis

This comment has been minimized.

DoctorSubtilis commented Apr 10, 2018

With 4.8 realease it seems possibile create a view, but is a empty view.

@DoctorSubtilis

This comment has been minimized.

DoctorSubtilis commented May 4, 2018

@mauriciofauth : when you think the bug will be fixed? Thank you.

@vividalllc

This comment has been minimized.

vividalllc commented May 14, 2018

I am experiencing this same issue with a new install of mysql and Joomla. Is there an update on this?

@mGGk-fr

This comment has been minimized.

mGGk-fr commented May 30, 2018

Hello guys !
Same problem here with the official docker image on latest tag (version 4.8.1).
Window open but it's empty.

@avkarenow

This comment has been minimized.

avkarenow commented Jun 18, 2018

I have a similar issue: after open new window on "Create view" I'm automatic log out. Everything else works fine.
Tested on PMA version 4.7.9 / 4.8.1 and PHP 5.6 / 7.1. My configuration has multiple servers.

@ibennetch ibennetch removed this from the 4.8.0 milestone Jul 7, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment