Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 55 lines (45 sloc) 1.264 kB
0f7e32c @FooBarWidget Initial import
FooBarWidget authored
1 source 'http://rubygems.org'
2
eabfcbe @FooBarWidget Upgrade to Rails 3.1.3
FooBarWidget authored
3 gem 'rails', '3.1.3'
0f7e32c @FooBarWidget Initial import
FooBarWidget authored
4
5 # Bundle edge Rails instead:
6 # gem 'rails', :git => 'git://github.com/rails/rails.git'
7
d9e9f05 @FooBarWidget Changes
FooBarWidget authored
8 gem 'schema_plus'
9 gem 'default_value_for'
fe89eba @FooBarWidget Changes
FooBarWidget authored
10 gem 'bluecloth'
3abf881 @FooBarWidget Add User model.
FooBarWidget authored
11 gem 'devise'
5682cad @FooBarWidget Install jQuery-Rails.
FooBarWidget authored
12 gem 'jquery-rails', '>= 1.0.12'
89092b4 @FooBarWidget Install pagination
FooBarWidget authored
13 gem 'will_paginate', '~> 3.0.pre4'
defbc24 @FooBarWidget Updates
FooBarWidget authored
14 gem 'css3buttons'
d6a764c @FooBarWidget Overhaul authorization by using cancan.
FooBarWidget authored
15 gem 'cancan'
3e6e110 @FooBarWidget Updates
FooBarWidget authored
16 gem 'inherited_resources'
d9e9f05 @FooBarWidget Changes
FooBarWidget authored
17
0f7e32c @FooBarWidget Initial import
FooBarWidget authored
18 # Deploy with Capistrano
19 # gem 'capistrano'
20
21 # To use debugger
22 # gem 'ruby-debug'
eabfcbe @FooBarWidget Upgrade to Rails 3.1.3
FooBarWidget authored
23 gem 'bcrypt-ruby'
0f7e32c @FooBarWidget Initial import
FooBarWidget authored
24
f64f12d @FooBarWidget Continue developing
FooBarWidget authored
25 group :development do
26 gem 'guard-livereload'
27 end
28
0f7e32c @FooBarWidget Initial import
FooBarWidget authored
29 # Bundle gems for the local environment. Make sure to
30 # put test-only gems in this group so their generators
31 # and rake tasks are available in development mode:
79550b8 @FooBarWidget Use RSpec and Capybara and add tests for ApiController.
FooBarWidget authored
32 group :development, :test do
a9af3b4 @FooBarWidget Add mysql2 to production Gemfile.
FooBarWidget authored
33 gem 'sqlite3-ruby', :require => 'sqlite3'
bb737a2 @FooBarWidget Make 'rake spec' work again
FooBarWidget authored
34 gem 'rspec-rails', '~> 2.4'
d5c7965 @FooBarWidget Make model reloading work in Spork.
FooBarWidget authored
35 gem 'capybara', :require => false
5ee33cb @FooBarWidget Update gems
FooBarWidget authored
36 gem 'capybara-webkit', :require => false
d5c7965 @FooBarWidget Make model reloading work in Spork.
FooBarWidget authored
37 gem 'database_cleaner', :require => false
38 gem 'factory_girl_rails', :require => false
39 gem 'launchy', :require => false
619be84 @FooBarWidget Continue developing
FooBarWidget authored
40 gem 'spork', '0.9.0.rc9', :require => false
79550b8 @FooBarWidget Use RSpec and Capybara and add tests for ApiController.
FooBarWidget authored
41 end
f368dd7 @FooBarWidget Update Gemfile
FooBarWidget authored
42
43 # Gems used only for assets and not required
44 # in production environments by default.
45 group :assets do
46 gem 'sass-rails', '~> 3.1.5'
47 gem 'coffee-rails', '~> 3.1.1'
48 gem 'uglifier', '>= 1.0.3'
49 end
a9af3b4 @FooBarWidget Add mysql2 to production Gemfile.
FooBarWidget authored
50
51 group :production do
52 gem 'mysql2'
53 # gem 'pg'
54 end
Something went wrong with that request. Please try again.